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Re� nik koriš � enih skra� enica 
  

ACLK Auxiliary Clock 

BATT Konektor koji slu�i za baterijsko napajanje plo� e 

BDM Background Debug Mode, hardversko debugging sredstvo za razvoj 

CPU Central Processing Unit, centralna procesorska jedinica 

DAC Digital-to-Analog Converter, digitalno-analogni konvertor 

DCO Digitally Controlled Oscillator, digitalno kontrolisani oscilator 

FET Flash Emulation Tool 

FLL Frequency Locked Loop 

HPF High-pass filter, filtar propusnik visokih u� estanosti  

I 2C Inter-Integrated Circuit komunikacioni protokol 

ICE In-Circuit Emulator, hardversko debugging sredstvo za razvoj 

IDE Integrated Development Environment, integrisano razvojno sredstvo 

ISS Instruction Set Simulator, softversko debugging sredstvo za razvoj 

JTAG Joint Test Action Group, hardversko debugging sredstvo za razvoj 

LAN Local Arrea Network, lokalna ra� unarska mre�a 

LCD Liquid Crystal Display, displej sa te� nim kristalom 

LED Light Emitting Diode, svetle� a dioda 

LPF Low-pass filter, filtar propusnik niskih u� estanosti 

OA Operational Amplifier, operacioni poja� ava�  

RAM Random Access Memory 

ROM Read-Only Memory 

RTC Real-time clock, sat realnog vremena 

SCC Source Code Control, upravljanje izvornim kôdom 
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SPI Serial Peripheral Interface 

UART Universal Asynchronous Receive Transmit 

USART Universal Synchronous Asynchronous Receive Transmit 

USB Universal Serial Bus, univerzalna serijska magistrala 

USCI Universal Serial Communication Interface, univerzalni serijski 
komunikacioni interfejs 

USI Universal Serial Interface, univerzalni serijski interfejs 

VCO Voltage-controlled oscillator, naponski kontrolisani oscilator 
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1. Uvod 
 
1.1. Struktura razvojnih sredstava  
  
 Uspešno projektovanje jednog embedded sistema podrazumeva dobro poznavanje 
principa rada svih njegovih hardverskih i softverskih gradivnih blokova, kao i njihovu 
me� usobnu interakciju. Pored poznavanja hardversko-softverskih komponenata veoma je va�no i 
da se dobro razume koja su razvojna sredstva (development tools) dostupna projektantima i od 
kakve su ona pomo� i kod implementacije embedded sistema. Razvoj i integracija razli� itih 
hardverskih i softverskih komponenata embedded sistema su prvenstveno mogu� i zahvaljuju� i 
pomo� i u radu koju pru�aju ova razvojna sredstva, a ti� u se slede� ih usluga: loadovanje softvera 
u hardver i ostvarivanje potpune kontrole  (upravljanje) nad razli� itim komponentama sistema.   
  
 Razvojno okru�enje se obi� no sastoji od:   
 
a)  embedded sistema - tj. sistema koji se razvija, ovaj sistem se � esto puta naziva target,  
b)  host - izveden kao PC mašina ili radna stanica na kojoj se razvija program.  
   
 Target i host se povezuju preko prenosnog medijuma, serijskom ili paralelnom vezom.  
 
 Razvojna sredstva embedded sistema mogu biti locirana u host-u, u target-u, ili mogu 
egzistirati kao nezavisne (stand-alone) jedinice. Ova sredstva se mogu svrstati u jednu od slede� e 
tri kategorije:  
  
•  utility tools - ovo su razvojna sredstva opšteg tipa koja su od pomo� i kod razvoja hardvera i 
softvera kakvi su editori (koriste se za unošenje izvornog programa), VCS (Versio Control 
Software) namenjen za upravlljanje softverskim fajlovima, ROM burners omogu� avaju da se 
softver upiše u ROM, i dr.   
 
•  translation tools - ova razvojna sredstva vrše konverziju kôda koga je projektant kreirao i 
namenio za target sistem u oblik (formu) koji je target u stanju da izvrši. Tu spadaju 
preprocesori, interpreteri, kompajleri, asembleri, i linkeri.   
 
•  debugging tools - ova razvojna sredstva se koriste za sle� enje traga izvršenja programa kao i 
korekciju grešaka u radu sistema, tj. lociranje i fiksiranje grešaka u sistemu. Tipi� na ovakva 
sredstva su In-Circuit Emulator (ICE), ROM emulator, Debugger, Profiler, Instruction Set 
Simulator (ISS), i dr. 
 

1.2. Karakteristike debugging sredstava   

 Pored aktivnosti koja se odnosi na kreiranje arhitekture embedded sistema, kreiranje 
debugging kôda je verovatno jedan od najte�ih zadataka u toku razvojnog ciklusa sistema. 
Debugging je zadatak kojim se lociraju i fiksiraju greške u sistemu.   
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 U Tabeli 1.1 prikazane su osnovne karakteristike debugging sredstava koje se kao jedinke 
mogu izvesti: i) kao samostalni uredaji; ii) kao deo host-a; i iii) da budu sastavni deo target 
plo� a.  
 
Tabela 1.1 Sredstva za razvoj 
 

Tip sredstva za 
razvoj 

Debugging sredstvo 
za razvoj 

Opis Primer koriš� enja i nedostaci 

hardver In-Circuit-Emulator 
(ICE) 

Aktivni ure� aj koji 
zamenjuje 
mikroprocesor u 
sistemu 

• obi� no je najskuplje debug 
rešenje, ali sa dosta 
debugging mogu� nosti  

• mo�e da radi punom 
procesorskom brzinom (u 
zavisnosti od ICE-a), a za  
ostatak sistema se ponaša 
kao  mikroprocesor  

• obezbe� uje da se u realnom 
vremenu  mogu videti i 
modifikovati interni sadr�aji 
memorije i sadr�aji registara 
i  promenljivih 

• sli� no debugger-ima 
omogu� ava postavljanje 
ta� aka prekida (breakpoints-
a)  i  ostvarivanje single 
stepping re�im rada  

• obi� no memorija koristi 
overlay memoriju za 
simulaciju ROM-a  

• procesorsko zavisna 

 ROM emulator Aktivno razvojno 
sredstvo koje 
zamenjuje ROM 
preko kablova 
povezanih na Dual 
port RAM u okviru 
ROM emulatora. To 
je uredaj tipa me� u-

• dozvoljava modifikaciju 
sadr�aja u ROM-u   

• mo�e da postavi ta� ke 
prekida u ROM kôdu, i da u 
realnom vremenu vidi ROM 
kôd  

• obi� no ne podr�ava rad sa 



�

	�
�

hardver koji se 
povezuje na target 
preko nekog kabla, tj. 
BDM, i povezuje se 
na host preko drugog 
porta. 

on-chip ROM-om, ASIC 
kolima, itd.   

• mo�e se integrisati na 
debugger-ima 

 Background Debug 
Mode (BDM) 

Komponente koje se 
koriste za debugging 
embedded sistema. 
BDM komponente 
� ine BDM hardver na 
plo� i (BDM port i 
integrisani debug 
monitor kod master 
CPU-a), i debugger 
na host-u (povezan 
preko serijskog kabla 
na BDM port). BDM 
debugging se 
ponekad naziva on-
chip debugging 
(OCD).   

• obi� no je jeftiniji od ICE, 
ali ne tako fleksibilan kao 
ICE  

• nadgleda izvršenje softvera 
u realnom vremenu na 
nenametljiv na� in  

• mo�e da postavi break-
point-e sa ciljem da zaustavi 
izvršenje softvera  

• omogu� ava � itanje i upis u 
registre, RAM, U/I portove, i 
td.  

• zavisan je od target 
procesora 

 IEEE 1149.1 Joint 
Test Action Group 
(JTAG) 

Hardver na plo� i koji 
radi u skladu sa 
JTAG preporukama. 

• sli� an BDM-u, ali nije 
specifi� nost neke arhitekture 
(otvoreni standard) 

 IEEE - ISTO 
NEXUS 5001 

Opcije JTAG porta, 
mora da radi u skladu 
sa NEXUS 
preporukama ili sa 
JTAG preporukama. 
Postoje nekoliko 
nivoa uskla� ivanja 
(sve u zavisnosti od 
slo�enosti master 
procesora, 
projektantskog izbora 
i td.) 

• u zavisnosti od nivoa 
uskla� ivanja hardvera nude 
se proširljive (scalable) 
debug funkcije 

 Osciloskop Pasivni analogni 
ure� aj koji na svom 

• u najve� em broju slu� ajeva 
se izvodi kao dvomlazni  
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displeju prikazuje 
talasni oblik napona, 
tj. promenu napona u 
funkciji vremena.   

• mo�e da radi u trigerskom 
re�imu rada kako bi se 
prikazivanje talasnih oblika 
vršilo u specifi� nim 
uslovima  

• mo�e da se koristi kao 
voltmetar za grubu procenu  

• mo�e da se koristi za 
verifikaciju rada kola 
posmatranjem talasnih 
oblika signala na U/I 
pinovima portova ili linija na 
magistrali  

• nezavisan je od tipa 
procesora 

 Logi� ki analizator Pasivan ure� aj koji 
simultano prihvata i 
sledi trag o ve� em 
broju signala, a 
tako� e i vrši njihov 
prikaz. 

• s obzirom na broj kanala 
koji se prihvataju (reda od 
20 do 200) cena je visoka  

• pravi razliku samo izme� u 
dva naponska nivoa (Vcc i 
masa), sve ostale signale 
tretira kao logi� ku 1 ili 0  

• mo�e da memoriše podatke 
(funkcija sli� na storage 
osciloskopu)  

• postoje dva re�ima rada:                      

 - timing: trigeruje se na 
promene stanja signala;                                                      

- state: registruje stanje 
signala  

• registruje promene signala 
na U/I portovima, sa ciljem 
da verifikuje izvršenja 
softverskih segmenata,  

izra� unava kašnjenje od 
jedne promene do druge, i 
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td. (timing mode)   

• mo�e da se trigeruje radi 
prihvatanja podatka u ritmu 
nekog taktnog signala na 
target plo� i ili u odnosu na 
interni takt logi� kog 
analizatora  

• mo�e da se trigeruje ako 
procesor u pojedinu sekciju 
u memoriji upisuje nevalidne 
podatke ili pristupa 
pojedinom tipu instrukcije 
(state mode)  

• mo�e da prika�e 
asemblerski kôd, ali ne mo�e 
da postavi ta� ku prekida ili 
da prisili CPU da radi u 
re�imu single-step   

• mo�e da nadgleda samo tok 
eksternih podataka, a ne i 
internih u odnosu na CPU, 
memoriju ili registre  

• nezavisan je od tipa CPU-a, 
sva nadgledanja signala se 
vrše u realnom vremenu 

 Voltmetar Meri naponsku 
razliku izme� u dve 
ta� ke u kolu. 

• meri pojedine naponske 
vrednosti  

• koristi se za proveru da li 
kolo ima napajanje   

• jeftiniji je u odnosu na 
ostala sredstva 

 Ommetar Meri otpornost 
izme� u dve ta� ke u 
kolu. 

• jeftin ure� aj  

• meri promene struje/napon 
u zavisnosti od otpornosti 
(V=I/R) 

 Multimetar Meri kako naponske • izvršava iste funkcije kao 
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razlike tako i 
otpornosti 

volt- i om-metar  

Softver Debugger Funkcionalno 
razvojno sredstvo za 
debugging. 

u opštem slucaju od 
debugger-a zavisi:  

• koji je kôd i kojoj je ciljnoj 
mašini namenjen radi 
loadovanja/aktiviranja 
re�ima rada korak-po 
korak/trasiranje  

• implementacija ta� aka 
prekida koje se koriste za 
stopiranje izvršenja softvera  

• implementacija uslovnih 
ta� aka prekida koje stopiraju 
izvršenje softvera ako je 
ispunjen pojedini uslov  

• mogu modifikovati sadr�aj 
RAM-a, ali ne i ROM 
memorije 

 Profiler Prikuplja timing 
istoriju o izabranim 
registrima, 
promenljlivama, i 
drugo. 

• prikuplja podatke o 
vremensko zavisnom 
ponašanju izvršenja softvera  

• prikuplja podatke o 
putevima izvršenja softvera i 
drugo 

 Monitor Debugging interfejs 
slican ICE-u, pri 
cemu se debug 
softver izvršava na 
target-u i host-u. Deo 
monitora se nalazi u 
ROM-u na target 
plo� i, a debugging 
kernel je na host-u. 
Softver na host-u i 
target-u obicno 
komuniciraju preko 

• sli� no kao print-iskaz ali 
ima br�i, manje nametljivi 
(intrusive), a tako� e radi 
bolje za soft -real time 
krajnje rokove, a ne za hard 
real time  

• sli� an po funkcionalnosti 
debugger-u (po tome što 
koristi ta� ke prekida, 
dumping registre i memoriju, 
i td.)  



�

���
�

serijskog kanala ili 
Ethernet-a, u 
zavisnosti od toga šta 
je instalirano na 
target-u. 

• embedded operativni 
sistemi mogu u sebi da 
sadr�e monitor za pojedine 
arhitekture 

 Instruction Set 
Simulator (ISS) 

Izvršavaju se na host-
u i memoriji (izvršivi 
binarni fajlovi se 
loaduju u simulator 
na na� in kao kad se 
loaduju u target) pri 
� emu simuliraju 
ponašanje hardvera 

• obi� no se ne izvršavaju 
istom brzinom kao i na 
realnom target-u, ali se 
mo�e proceniti vreme odziva 
i propusnost sistema imaju� i 
u vidu razliku u brzini rada 
izmedu host-a i target-a  

• verifikuju asemblerski 
jezik sa ciljem da utvrde da 
ne postoje bug-ovi (greške)   

• obi� no ne simuliraju drugi 
hardver koji postoji na 
target-u, ali omogu� avaju 
testiranje komponenata koje 
su ugra� ene u procesor 
(tajmer, PIA, i td.)  

• mogu simulirati ponašanje 
prekida  

• � uvaju trag o 
promenljivim, memorijskim, 
i registarskim vrednostima  

• lako je preneti kôd razvijen 
na simulatoru u target sistem  

• precizno simuliraju 
ponašanje aktuelnog 
hardvera u realnom vremenu  

• obi� no su pogodniji za 
testiranje algoritama, a ne za 
testiranje arhitekture na 
reakcije generisane od strane 
spoljnih doga� aja (misli se 
na talasne dijagrame)  
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• jeftinije su kao investicija 
od realnog hardvera i 
sredstava za razvoj 

Manuelno Lako dostupni, jeftiniji od ostalih rešenja, nelicencirano koriš� enje, 
jednostavni za koriš� enje, ali vidljivi za softver koji se izvršava, ne postoji 
dovoljno dobra kontrola nad selektovanim doga� ajima, izolovani su, 
repetitivni. Postoje problemi kod debagiranja real time sistema posebno 
kada je vreme izvršenja manuelnih metoda suviše dugo. 

 Iskazi tipa print Funkcionalno 
debugging sredstvo. 
Printing iskaz se 
insertuje u kôd koji 
štampa informaciju o 
promenljivoj, lokaciji 
informacije u kôdu, 
itd. 

• cilj je da se vidi vrednost 
promenljive, sadr�aj registra 
i dr., u toku izvršenja 
programa  

• verifikuje se segment kôda 
koji se izvršava  

• mo�e zna� ajno da uspori 
vreme izvršenja  

• mo�e uzrokovati 
nekorektne krajnje rokove 
izvršenja kod real time 
sistema   

 Dump Funkcionalno 
debugging sredstvo 
koje u toku 
izvršavanja programa 
smešta podatke na 
neki tip memorijskog 
medijuma.   

• isto kao i print iskazi samo 
što se izvršava br�e  

• potrebno je da se proverava 
sadr�aj memorije u toku 
izvršenja programa kako ne 
bi došlo do prekora� enja 
prostora heap-a i magacina 

 Broja� i/Tajmeri Debugging sredstva 
za procenu 
performansi i 
efikasnosti, pri � emu 
se tajmeri ili broja� i 
resetuju i 
inkrementiraju u 
razli� itim ta� kama 
programa. 

• skupljaju informaciju koja 
se odnosi na opšti tajming 
izvršenja, broje� i taktne 
impulse, cikluse na 
magistrali, itd. 
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 Brzo prikazivanje Funkcionalno 
debugging sredstvo 
koje pali i gasi LED 
diode ili koristi LCD 
displej za prikaz 
podataka. 

• sli� no kao print iskaz ali 
br�e, manje vidljivo, 
pogodnije je za rad kod 
manipulisanja sa real time 
krajnjim rokovima  

• potvr� uje da se specifi� ni 
deo kôda izvršava 

 Izlazni portovi Funkcionalno 
debugging sredstvo 
za procenu 
performansi i 
efikasnosti pri � emu 
se izlazni portovi u 
razli� itim ta� kama 
izvršenja programa 
postavljaju na 
odre� ene vrednosti 

• pomo� u odre� enog 
osciloskopa ili logi� kog 
analizatora analizira se stanje 
kada se izlaz porta, u toku 
izvršenja programa, postavi 
na odre� enu vrednost  

• multitasking i 
multithreading sistemi 
dodeljuju razli� ite portove 
svakom thread/zadatak sa 
ciljem da se proceni 
ponašanje sistema    

�
 
 
 

1.3. Hardverska sredstva za debugging - struktura   
 
1.3.1 ICE  
 
 Do skoro, (kraj 90-ih godina prošlog veka) glavni pristup u razvoju mikroprocesorskih 
sistema je bio baziran na ICE konceptu. Kao prvo, ciljni sistem se izvodio na štampanoj plo� i na 
koju su se ugra� ivali mikroprocesorski � ip, memorija, i razne periferne komponente. Da bi se 
ICE mogao koristiti, mikroprocesor se vadio iz podno�ja na štampanoj plo� i i na njegovo mesto 
se postavljao header plug (konektor) koji je bio "pup� anim" putem (kablovski) povezan sa ICE 
opremom (vidi sliku 1.1).  
 ICE je emulirao funkciju mikroprocesora i obezbe� ivao je korisniku jedan unutrašnji 
uvid u interno stanje sistema, obezbe� uju� i pristup radi � itanja i modifikovanja sadr�aja registara 
procesora, memorijskih lokacija, postavljanje prekidnih ta� aka, i dr.   
 Danas kada su mikroprocesori postali samo manji deo slo�enih � ipova pristup baziran na 
ICE konceptu nije više primenlljiv. Razlog je slede� i: Nemogu� e je da se izdvoji deo VLSI � ipa i 
njemu posebno pristupi (misli se na core procesora). No ve� i broj tehnika i pristupa testiranja 
dizajna koji je bio koriš� en kod ICE-a zadr�an je danas i kod testiranja VLSI integrisanih kola. 
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Slika 1.1 Blok dijagram emulatorsko upravlja� kog sistema 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.1 
 

  
Target system Ciljni sistem 

Emulator Emulator 

Logic Analyzer Logi� ki analizator 

Target memory Ciljna memorija 

Processor footprint Podno�je procesora 

Shadow RAM and ROM Shadow RAM i ROM 

Microprocessor Mikroprocesor 

MUX Multiplekser 
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Addr. Bus Buffers  Baferi adresne magistrale 

Data Bus Buffers Baferi magistrale podataka 

Memory Steering Logic Memorija kontrolne logike 

NMI Control Logic NMI Kontrolna logika 

Real-Time Trace Memory Real-Time Trace memorija 

Trace Trigger System Trace Trigger sistem 

�
�
 

1.3.2 ROM emulator  
 
  
 ROM emulator � ine slede� i sistemski elementi :  
 
• kablovi sa odgovaraju� im konektorima koji se mehani� ki povezuju na podno�je ROM 
komponente ciljnog sistema  
•  brzi RAM tipa dual port RAM zamenjuje ROM u ciljnom sistemu  
•  lokalni upravlja� ki procesori  
•  komandni port (portove), za vezu sa host-om  
•  dodatne logike kakva je trace memorija i logika za podršku rada algoritama za programiranje 
fleša.  
  
 Na slici 1.2 a) prikazan je funkcionalni blok dijagram tipi� nog ROM emulatora, a na slici 
1.2. b) na� in povezivanja ROM emulatora sa host-om i target-om.   
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Slika 1.2 ROM emulator: a) funkcionalni blok dijagram, b) šematska prezentacija  
 

 
Napomena: Objašnjenje skra� enica sa slike 1.2. a) 

 
Communication Buffer Region 
of RAM (Dual-ported for 
Simultaneous Access) 

Komunikaciona bafer regija RAM-a 
(Dual-port za istovremeni pristup) 

Fast RAM Memory Array (512K 
to 8MB bytes, typical) 

Polje brzog RAM-a (512K do 8MB, 
tipi� no) 

Control Processor Upravlja� ki procesor 

Gating and Signal Steering 
Logic 

Odabir i signaliziranje kontrolne 
logike 

Cable Drivers/Buffer Kabl drajver (pobudni stepen za 
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Circuitry kabl)/ Bafersko kolo 

Real-Time Trace Memory 
Buffer (Optional) 

Bafer Real-Time Trace memorije 
(opciono) 

Cable Kabl 

Active Cable Interface 
Circuitry (Optional) 

Aktivno kabl interfejs kolo (opciono) 

Mechanical Interface to ROM 
Socket or Device 

Mehani� ki interfejs ka ROM 
podno�ju ili ure� aju 

Communications interface to 
Host 

Komunikacioni interfejs ka host-u 

To Target System Ka ciljnom sistemu 

To Host Computer Ka Host ra� unaru 

�
�

Napomena: Objašnjenje skra� enica sa slike 1.2. b) 
 

LAN, serial or parallel LAN, serijski ili paralelno 

Simple plug-in probe 
substitutes for system ROMs 

Jednostavne plug-in probne zamene za 
sistemske ROM 

Main chassis - 

         - overlay memory 

         - trace capability 

         - system control 
and host interface 

Glavne odlike - 

    - overlay memorija 

    - trace sposobnost 

    - kontrola sistema i host interfejs 

Target system Ciljni sistem 

�
 
 

1.3.3 Background Debug Mode (BDM)  
  
 BDM kao  debug  interfejs prvi put je bio implementiran od strane kompanije Motorola 
sa familijom MC 683xx, a koriš� en za ColdFire familiju porcesora.  
 Na slici 1.3, na šematskom nivou prikazano je kako se embedded sistem povezuje na host 
ra� unar koriste� i n-�ilnu vezu sa procesorskim debug jezgrom (n-�ilna veza se naziva wiggler).  
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Slika 1.3 n-�ilno povezivanje kod BDM-a  
 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.3 
 
 

LAN, serial or 
parallel 

LAN, serijski ili paralelno 

Translates LAN data 
stream to n-wire 
commands 

Prevodi LAN niz podataka u n-�ilne 
komande 

n-wire connection to 
debug circuitry built 
into processor 

n-�ilna veza sa procesorskim debug 
jezgrom 

Target system Ciljni sistem 

�
 

Prednosti: 
·  Jednostavno mehani� ko povezivanje 
·  Radi sa mikropotrošnjom na target-u 
·  Nezavisno od µP varijanti 
·  Jednostavna konstrukcija alata 
·  Mala cena, mogu� a ponovna upotreba, jednostavno 
·  Si isporu� ilac snosi troškove podrške  
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Mane: 
·  Mnogi podr�avaju samo run kontrolu 
·  Set alata je ograni� en na ono što nudi Si isporu� ilac 
·  Mo�e biti vrlo sporo 
·  Nema podršku za overlay memoriju 
·  Nema pristup drugim magistralama 

 
 

 Na ciljnoj štampanoj plo� i BDM se povezuje preko 26-pinskog konektora. Raspored 
pinova na BDM debug interfejsu je dat na slici 1.4.  
 
 

 
 

Slika 1.4 Raspored pinova kod debug interfejsa firme Motorola  
 

 
Napomena: Objašnjenje skra� enica sa slike 1.4 
 

Reserved Rezervisano 

Ground Masa 

Reset Reset 

+5 Volts +5 volti 

Breakpoint Ta� ka prekida 

�
 

 � etiri bita DDATA0-DDATA3 su namenjena za prenos izlaznih debug podataka, a � etiri 
bita PST0-PST3 ukazuju na izlazni status procesora u toku rada. U tabeli 1.2 su prikazani izlazni 
kôdovi procesora koji se prezentiraju na pinovima PST0-PST3.   
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Tabela 1.2. Izlazni kôdovi procesora 
 

PST3-PST0 Definicija 

0000 Nastavlja izvršavanje 
0001 Zapo� inje izvršavanje instrukcije 
0010 Rezervisano 
0011 Ulazak u user re�im rada 
0100 Zapo� inje izvršavanje PULSE ili WDDATA instrukcije 
0101 Zapo� inje izvršavanje izabrane grane 
0110 Rezervisano 
0111 Zapo� inje izvršavanje RTE instrukcije 
1000 Zapo� inje 1-bajtni transfer na DDATA 
1001 Zapo� inje 2-bajtni transfer na DDATA 
1010 Zapo� inje 3-bajtni transfer na DDATA 
1011 Zapo� inje 4-bajtni transfer na DDATA 
1100 Procesiranje izuzetaka (podr�ano za višestruke cikluse) 

1101 Ulaz u tabelu za procesiranje izuzetaka koja ukazuje na 
rutinu za re�im rada emulator (kao gore) 

1110 Procesor je stopiran, � eka prekid (kao gore) 
1111 Procesor je halted (zaustavljen) (kao gore) 

�
 

 Skup BDM komandi koje se odnose na Motorola ColdFire procesorsku familiju su 
prikazani u tabeli 1.3. 
 
 
Tabela 1.3. Skup komandi BDM-a 
 

Komanda Mnemonik Opis Uticaj na CPU  

Read A/D Register RAREG/RDREG � ita odabrani registar i 
vra� a rezultat preko 
serijskog BDM interfejsa 

Halted 

Write A/D 
Register 

WAREG/WDREG Podaci su upisani na 
specifi� nu adresu ili registar 
podataka pomo� u serijskog 
BDM interfejsa 

Halted 

Read Memory 
Location 

READ � ita podatke sa memorijske 
lokacije odre� ene adresom 
duga� ke re� i 

Cycle Steal 

Write Memory 
Location 

WRITE Upisuje podatke na 
memorijsku lokaciju 
odre� enu adresom duga� ke 
re� i 

Cycle Steal 

Dupm Memory Block DUMP Koristi se zajedno sa READ Cycle Steal 
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komandom za pra�njenje 
velikih delova memorije 

Fill Memory Block FILL Koristi se zajedno sa WRITE 
komandom za punjenje 
velikih delova memorije 

Cycle Steal 

Resume Execution GO Proto� ni stepen se prazni i 
ponovo puni pre nego što se 
nastavi sa izvršenjem 
instrukcija sa teku� e 
vrednosti programskog 
broja� a. (PC registar) 

Halted 

No Operation NOP NOP ne izvršava nikakvu 
operaciju i mo�e se koristiti 
kao prazna komanda 

Parallel 

Read Control 
Register 

RCREG Iš� itava system control 
registar 

Halted 

Write Control 
Register 

WCREG Upisuje podatke u system 
control registar 

Halted 

Write Debug 
Module Register 

WDMREG Upisuje podatke u Debug 
Module registar 

Halted 

Napomene: Opšti uticaj BDM komandi na operacije sistema: 

1. Halted – CPU mora biti zadr�an (zaustavljen) da bi izvršio ovu komandu 

2. Cycle Steal – Komanda generiše ciklus magistrale koji je isprepletan sa CPU pristupima 

3. Parallel – Komanda je izvršena paralelno sa aktivnoš� u CPU-a 
 
 
 
 

1.3.4 Joint Test Action Group (JTAG)  
  
 JTAG (IEEE 1149.1) protokol je evoluirao kao posledica rada koji se odnosi na testiranje  
štampanih plo� a u industriji.  
 JTAG je prvenstveno projektovan da zameni tradicionalni na� in testiranja štampanih 
plo� a, kod slo�enih mašina, koji se zasnivao na konceptu koriš� enja gustih polja ta� aka-pristupa 
(nazvanih bed ili nails). Ta� ke pristupa kontaktiraju svaki � vor (node) na plo� i (� vor predstavlja 
deljivu vezu izme� u komponenata na plo� i).   
 Kod JTAG pristupa ideja je slede� a: Tester plo� e povezuju sve � vorove na plo� i na 
individualne bitove jednog duga� kog pomera� kog registra. Svaki bit odgovara jednom � voru. Da 
bi JTAG bio operativan neophodno je da svako integrisano kolo bude projektovano na takav 
na� in da podr�i JTAG protokol. To zna� i da svaki U/I pin integrisanog kola treba da sadr�i (ima 
interno ugra� eno) pridru�eni element (interfejs logiku) koja je sastavni deo JTAG lanca.  
 
 Na slici 1.5. skicirana je jedna jednostavna JTAG petlja za tri elementa.  
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Slika 1.5. Šematski prikaz JTAG petlje za tri elementa na štampanoj plo� i 
 
 
Napomena: Objašnjenje skra� enica sa slike 1.5 
 

 
Each JTAG cell “sniffs” 
the state of the 
corresponding output bit 
of the IC 

Svaka JTAG � elija “uvla� i” stanje 
odgovaraju� eg izlaznog bita integrisanog kola 

JTAG Connector JTAG konektor 

JTAG bit stream in Ulaz JTAG niza bitova 

JTAG bit stream out Izlaz JTAG niza bitova 

PC Board Štampana plo� a 

�
 

 Danas veliki broj mikroprocesora se fabrikuje tako da, u cilju efikasnijeg testiranja 
njegovog rada, ima izvedeno JTAG zasnovano debagiranje jezgra-procesora. Na slici 1.8. 
prikazana je jedna tipi� na JTAG petlja koja ilustruje kako se vrši testiranje gradivnih blokova 
CPU-a.   
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Slika 1.6. Debagiranje jezgra CPU-a zasnovano na konceptu JTAG-a 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.6 
 

 
Clock in  Ulaz takta 

JTAG in JTAG ulaz 

JTAG out JTAG izlaz 

Program Counter – PC Programski broja�  

Register R1,...,Rn Registar R1,...,Rn 

Status Bus Interface Status Bus Interfejs 

JTAG Control State 
Machine 

JTAG mehanizam za kontrolu stanja 

Processor Core Core procesora 

Special Register Set Set registara specijalne namene 

Data Bus Interface Baferi magistrale podataka 

Addr Bus Interface Baferi adresne magistrale 

�
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 Za implementaciju JTAG-a koristi se serijski protokol, koji zahteva da relativno mali broj 
U/I pinova mikroprocesora podr�ava mogu� nost debagiranja. Spisak pinova za IEEE 1149.1 
(JTAG) interfejsa prikazan je u tabeli 1.4.  
 
 
Tabela 1.4. Opis pinova JTAG interfejsa 
 

PIN Opis 

TCK Ulaz takta koji sinhronizuje logi� ke operacije JTAG porta 
TMS Selektorski ulaz za test re�im rada koji se uzorkuje sa uzlaznim impulsom 

TCK-a radi sekvenciranja internog stanja kontrolera (TAP Controller) 
TDI Ulazni testni niz podataka koji se uzorkuje sa uzlaznim impulsom TCK-a 
TDO Izlazni testni niz podataka koji se a�urira sa opadaju� im impulsom TCK-a 
TRST Asinhroni reset aktivan na niskom nivou 

 
 
 
 

1.3.5 Nexus interfejs  
  
 U aprilu 2001. godine organizacija IEEE je donela preporuke pod nazivom IEEE-ISTO-
5001. Ovaj standard je uveo nekoliko novih koncepata koji se ti� u debagiranja embedded 
procesora. Prvi se odnosi na proširljivost (scalability). Kompatibilnost u radu procesora i 
standarda se mo�e ostvariti na nekoliko nivoa uskla� ivanja. Prvi nivo se odnosi na jednostavne 
run kontrolne komande. Svaki naredni nivo uvodi ve� i broj mogu� nosti, ali, za implementaciju, 
zahteva od procesora ve� i broj pinova. Na najni�em nivou uskla� ivanja Nexus koristi JTAG 
protokol (IEEE 1149.1) kao standardni protokol.   
  
 Na slici 1.7. prikazana je osnovna struktura Nexus interfejsa.   
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�
·  Razvojni interfejs: 

                               - samo 1149.1 port 
                               - samo Auxiliary (Nexus) port  
                               - 1149.1+ Auxiliary portovi 

·  U saglasnosti sa klasama: 1, 2, 3, 4 
     - Fiksne stati� ke razvojne (tehni� ke) karakteristike 
     - Promenljive dinami� ke razvojne karakteristike 
 
 

Slika 1.7.  Nexus interfejs 
 
 

 Treba naglasiti da se skalabilnost interfejsa prote�e od osnovne  run-control mogu� nosti 
do dinami� kog debugging-a, tj. mogu� nosti trasiranja kod rada u realnom vremenu.   
  
 
 
1.3.6 Logi� ki analizator  
  
 Kada projektant �eli da ustanovi šta, u realnom vremenu, radi procesor, a da pri tome ne 
izvrši neke zna� ajne dorade u hardveru embedded sistema, tada je svrsishodno da kao debugging 
sredstvo koristi logi� ki analizator. U suštini, logi� ki analizator je veoma mo� no sredstvo koje  se 
koristi za ispitivanje rada digitalnih sistema.   
  
 Logi� ki analizator mo�e da radi u slede� a dva re�ima rada: timing i state.  
 
 U re�imu rada timing, interna visoka-frekvencija rada logi� kog analizatora (> 400 MHz 
�  2.5 ns period uzorkovanja), odre� uje kada � e se u memoriji logi� kog analizatora prihvatiti 

Embedded 
Procesor 

1149.1 port 1149.1 protokol: konfiguracija i status, 
pristup standardnim razvojnim 
registrima, pristup za � itanje/pisanje 
tokom rada, � itanje paketskih poruka  

Aux. ulazni 
port 

Aux. 
izlazni port 

Debugger, podešavanje parametara 
izvršavanja, paketske poruke  

Debugger, logi� ki analizator, 
akvizicija podataka, prototipovi 
paketskih poruka 
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slika o stanju procesora, ili procesora i drugih digitalnih kola sistema. Standardno logi� ki 
analizator ima ve� i broj ulaznih sondi (od 20 do 200) koje se koriste za prihvatanje ulaznih 
signala. Sa periodom uzorkovanja od 2.5 ns, memorija obima 200 bitova, i dubine 106 stanja 
(lokacija), za slu� aj da procesor radi na frekvenciji od 100 MHz, mogu� e je da se prihvate 
250000 ciklusa procesora na magistrali. Prikaz informacije koju logi� ki analizator pribavlja vrši 
se na CRT displeju. Jedan tipi� an prikaz dat je na slici 1.8. 
 
  

 
 

Slika 1.8. Prikaz logi� kog analizatora koji se odnosi na pojednostavljeni vremenski dijagram za 
32-bitni mikroprocesor  

 
 

Napomena: Objašnjenje skra� enica sa slike 1.8 
 
 

Clock Takt 

Op Code Operacioni kôd 

Read � itanje 

Write Pisanje 

Processor clock Takt procesora 

Op Code fetch cycle  Ciklus pribavljanja operacionog kôda 

Memory read Operacija � itanja memorije 
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operation 

Memory write 
operation 

Operacija upisivanja u memoriju 

32 Address Lines 32 adresne linije 

32 Data Lines 32 linije podataka 

Operand read cycle Ciklus � itanja operanda 

Instruction cycle Instrukcioni ciklus 

 

 U re�imu rada state, logi� ki analizator koristi takt procesora da bi uzorkovao stanje 
signala. To zna� i da svaki put kada taktni signal CPU-a ima prelaz sa niskog na visoko, logi� ki 
analizator uzorkuje stanje na pinovima i upisuje to stanje u memoriju analizatora. U ovom 
slu� aju relativna timing informacija izme� u signala se gubi, ali se mogu videti vrednosti tih 
signala. Najve� i broj logi� kih analizatora, kao softverske pakete ima dostupno disasemblere. 
Disasembler je u stanju da redukuje broj snimljenih signala od strane logi� kog analizatora i da ih 
prika�e na displeju u tabelarnoj formi kao mnemonike instrukcija na asemblerskom jeziku, 
adresne infomacije, � itanje operanada ili upis, prikaz specijalne statusne informacije (kakvi su 
ciklusi instrukcija za obradu prekida), i drugo. Na slici 1.9. ilustrovan je jedan primer 
prezentacije podataka od strane logi� kog analizatora kada ovaj radi u state re�imu rada, a odnosi 
se na trasiranje izvršenja kod procesora iz familije Motorola MC68K.  
 
 

 
 

Slika 1.9. Prikaz na ekranu kada logi� ki analizator radi u re�imu state  
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1.4. Softverska utility  razvojna sredstva  
 
 
 Izvorni kôd se obi� no piše koriš� enjem razvojnih sredstava kakva su standardni ASCII 
tekst editor ili IDE (Integrated Development Environment). Ovaj tip razvojnog sredstva je lociran 
na host-ovoj platformi (vidi sliku 1.10.).  
 

  
 

Slika 1.10. IDE  
 

 IDE predstavlja skup razvojnih sredstava, uklju� uju� i i ASCII tekst editor, integrisanih u 
jedinstveni aplikaciono-korisni� ki interfejs. U principu, bilo koji ASCII tekst editor mo�e se 
koristiti za pisanje bilo kog kôda, nezavisno od jezika i platfome. Sa druge strane, IDE je 
specifi� no sredstvo za datu platformu, koje nudi proizvo� a�  i u najve� em broju slu� ajeva 
sastavni je deo ponude proizvodaca, kakav je slucaj sa starter kit-om (� ine ga hardverska plo� a i 
IDE), operativnim sistemom (MS Windows ili Linux), ili programskim jezikom (Visual C). 
 
 
1.4.1. Translation razvojna sredstva 
 
 
 Hardverske komponente u okviru embedded sistema mogu direktno da prenose, 
memorišu, i izvršavaju mašinski kôd, koji je osnovni jezik koga � ine logi� ke jedinice i nule. Kao 
jezik, mašinski kôd je bio koriš� en u ranijoj fazi ra� unarskih sistema (negde 50-ih godina prošlog 
veka). Pisanje programa ovakvim na� inom kôdiranja je bilo veoma teško i podlo�no brojnim 
greškama. Sa ciljem da se programiranje u� ini efikasnijim u� injen je pokušaj da mašinski kôd 
bude vidljiviji programeru, što je izvedeno putem kreiranja hardversko-specifi� nog skupa 
instrukcija, nazvan asemblerski jezik. Tokom vremena, drugi programski jezici, kakvi su C, C++, 
Java i td. su evoluirali. Osnovna karakteristika ovih jezika, koje nazivamo višim programskim 
jezicima, je ta da poseduju hardversko-nezavisne skupove instrukcija, semanti� ki su nezavisne 
od mašine, i podse� aju na jezike koje koriste ljudi. S obzirom da je mašinski jezik jedini jezik 
koga hardver mo�e direktno da izvršava, svim ostalim jezicima je potreban neki tip mehanizma 
pomo� u koga bi oni bili u stanju da generišu odgovarajuci mašinski kôd. Ovaj mehanizam 
obi� no predstavlja kombinaciju preprocesiranja, translation (prevo� enje) i interpretacije.   



�

���
�

 U zavisnosti od jezika, translation mehanizmi postoje (instalirani su i izvedeni) na host 
sistemu (obi� no je to non-embedded razvojni sistem kakva je PC mašina ili neka radna stanica) 
ili na ciljnom sistemu (embedded sistem koji se razvija), kao što je to prikazano na slici 1.11.  
 

 
 

Slika 1.11. Host-target sistemski dijagram 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.11 
 

 
Host (Development System) Host razvojni sistem 

Application Layer Sloj aplikacija 

Preprocessor Preprocesor 

Compiler Kompajler 

Linker Linker 

System Software Layer Sloj sistemskog softvera 

Hardware Layer Sloj hardvera 

Target (Embedded System) Target (Embedded sistem) 

 

 
Preprocesiranje je opcioni korak koji postoji pre translation i interpretacije izvornog 

kôda, i � ija se funkcionalnost standardno implementira od strane preprocesora. Zadatak 
preprocesora je da organizuje i restruktuira izvorni kôd sa ciljem da u� ini translation i 
interpretaciju kôda lakšim. Tako na primer, kod jezika kakvi su C i C++ , preprocesor 
omogu� ava da se koriste imenovani kôdni fragmenti, kakvi su makroi. Makroi obezbe� uju da se 
pojednostavi razvoj programa dozvoljavaju� i da se u programu koriste macro-imena pomo� u 
kojih se zamenjuju fragmenti kôda. U toku preprocesiranja, preprocesor zamenjuje macro-ime sa 
sadr�ajem makroa. Preprocesor mo�e da postoji kao poseban entitet, ili da bude integrisan u 
okviru translation ili interpretatorske jedinice.    
 Najve� i broj jezika konvertuje izvorni kôd, bilo direktno ili nakon preprocesiranja, 
pomo� u kompajlera na pojedini ciljni jezik (vidi sliku 1.12).  
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Slika 1.12. Dijagram kompilacije  
 

 
Napomena: Objašnjenje skra� enica sa slike 1.12 
 

 
Source Code Izvorni kôd 

Compiler Kompajler 

Preprocessing Preprocesiranje 

Compiling Kompilacija 

Target Code Ciljni kôd 

Header File(s) for 
languages like C and C++ 

Header fajl (ovi) za jezike kao C i 
C++ 

�
 

 Kod embedded sistema, kompajleri su obi� no locirani u host mašini, a generišu ciljni kôd 
za hardversku platformu koja se razlikuje od platforme na kojoj se kompajler izvršava. Ovakve 
kompajlere nazivamo kros-kompajleri . Kada je re�  o asemblerskom jeziku, kompajler je, u 
suštini, specijalizovani kros-kompajler koji se naziva asembler i on uvek generiše mašinski kôd. 
Kod viših programskih jezika kompajleru se obi� no pridru�uje ime jezika, kakav je slu� aj sa C-
kompajlerom, Java-kompajlerom itd. 
Nakon što se na host mašini kompilacija završi, generiše se objektni fajl. Objektni fajl se zatim 
linkuje (povezuje) sa bibliote� nim sistemskim fajlovima u jedinstveni fajl koji se standardno 
naziva executable (izvršivi binarni fajl). Executable se nakon toga loaduje u memoriju ciljnog 
embedded sistema (vidi sliku 1.13.) uz pomo�  loadera.   
 



�

���
�

 
 
 

Slika 1.13. Koraci kompilacije/linkovanja objektnog fajla za slu� aj programskog jezika C  
 

 
Napomena: Objašnjenje skra� enica sa slike 1.13 
 

 
C Source File (s) C izvorni fajl (ovi) 

C Compiler C Kompajler 

Preprocessing Preprocesiranje 

Compiling Kompilacija 

C Object File (s) C objektni fajl (ovi) 

Linker Linker 

C Executable File C izvršni fajl 

C Header File (s) C  Header fajl (ovi) 

C System Libraries C sistemske bibloteke 

Host Computer Host ra� unar 

Embedded System Embedded sistem 

�
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 Jedna od osnovnih karakteristika translation procesa se zasniva na konceptu razmeštaja 
softvera (nazvan object placement), sposobnost da se softver podeli na module i da se moduli 
kôda i podataka smeste u memoriji tamo gde je to potrebno. Ova karakteristika je od izuzetne 
va�nosti kod embedded sistema iz slede� ih razloga:   
  
1.  embedded dizajn karakteriše nekoliko razli� itih tipova fizi� ke memorije,  
2.  u odnosu na ra� unare opšte namene iznos memorije kod embedded sistema je ograni� en,  
3.  memorija je obi� no izrazito fragmentirana (podeljena), i  
4.  odre� eni tipovi (delovi) embedded softvera se � esto izvršavaju iz pojedinih delova memorije.  
  
 Softver za razmeštanje kôda i programa u memoriji embedded ra� unara mo�e da bude 
sastavni deo: a) host-a, generišu� i pri tome specijalizovane instrukcije koje se koriste za 
generisanje "poziciono nezavisnog kôda"; ili b) mo�e biti sastavni deo softverskih translation 
razvojnih sredstava. U oba slu� aja, ova mogu� nost zavisi od toga da li asembler/kompajler mo�e 
da: i) procesira samo apsolutne adrese (po� etna adresa je fiksirana od strane softvera pre nego što 
asembler procesira kôd); ili ii) koristi relativno adresiranje, tj. po� etna adresa kôda se mo�e 
specificirati kasnije, prevedeni moduli su relokatibilni, a razmeštaj softvera se obavlja od strane 
linkera.   
 Kod IDE, procesori, kompajleri i linkeri se nalaze u host razvojnom sistemu, neki jezici, 
kakav je Java ili neki script jezici, imaju kompajlere ili interpretere koji su locirani u target-u. 
Interpreter generiše mašinski kôd prevode� i liniju po liniju izvornog kôda ili ciljnog kôda (vidi 
sliku 1.14).   
 

 
 

Slika 1.14. Dijagram interpretacije 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.14 
 

Source L1,...,L6 Izvorni  kôd L1,...,L6 

Target Code for Source L1,...,L6 Ciljnog kôd za izvorni  kôd L1,...,L6 
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1.5. Softverska sredstva za debugging – struktura 
 
 
Debugger  
  
 Debugger-i kod embedded sistema sastoje se od slede� e dve celine: a) deo debugger-a 
koji se nalazi u host-u; i b) deo debugger-a koji se nalazi u target sistemu. Oba elementa 
debugger-a me� usobno komuniciraju preko komunikacionog kanala, kakav je onaj koji se 
realizuje preko serijskog RS-232 ili Ethernet porta. Deo debugger-a koji se nalazi u target-u 
naziva se target agent ili debug kernel, a deo koji je instaliran u host-u se naziva debugger front 
end ili GUI.  
 Klju� ni zadaci koje obavlja debugger su slede� i:  
•  postavlja ta� ke prekida  
•  loaduje programe od host-a  
•  nadgleda ili modifikuje sadr�aj memorije ili registra  
•  startuje izvršenje programa od odre� ene adrese  
•  uslovljava da procesor radi u re�imu rada korak-po-korak  
  
 Debug kernel (ili target agent) zahteva da target poseduje slede� a dva resursa: vektor 
prekida i softverski prekid. Na slici 1.15. prikazan je na� in integracije debugger-a sa target 
kôdom.  
 
 

 
 
 

Slika 1.15. Debug kernel target sistema 
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Napomena: Objašnjenje skra� enica sa slike 1.15 
 
 

Host-Based Debugger Program 

  - Knowledge of source files 

  - Knowledge of object files 

     > Symbol table 

     > Cross reference files 

Host bazirani Debugger program 

        - poznavanje izvornih fajlova 

        - poznavanje objektnih fajlova 

              > Simbol tabela 

              >  Cross reference fajlovi 

Serial Comm Link Serijski komunikacioni link 

System ROM Code Partition Code particija sistemskog ROM-a 

Power On Reset Code Power On Reset kôd, reset kôd koji 
odgovara uklju� enju sistema 

Serial Port ISR Serijski port ISR 

Debug Kernel Debug kernel 

Application Program Aplikacija 

Software Debug Trap Vector Softverski trap vektor za debagiranje 

Serial Port Int. Vector Prekidni vektor za obradu informacija sa 
serijskog porta 

�
 
 

Prekidna ta� ka  
  
 Prekidna ta� ka (breakpoint) je debugging mehanizam (hardverski ili softverski), koji 
stopira CPU da izvrši kôd.   
 Da bi razumeli kako se breakpoint postavlja, na odre� eno mesto u programu, 
analizira� emo sliku 1.16.   
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Slika 1.16. Prekidne ta� ke (breakpoints) 
 
 

Napomena: Objašnjenje skra� enica sa slike 1.16 
 
 

Code image in memory: before Izgled kôda u memoriji: pre 

Instruction Instrukcija 

Want to set breakpoint here �elimo da ovde postavimo ta� ku prekida 

Code image in memory: after Izgled kôda u memoriji: posle 

Trap vector to debugger 
entry point 

Trap vektor za ulaz u debugger 

Debugger inserts trap vector 
in place of instruction 

Debugger insertuje trap vektor na mesto 
instrukcije 

Moved to the debugger 
database for safe keeping 

Kopiranje u bazi podataka debugger-a 
radi � uvanja stanja 

�
  
 Neka u programu kreiranom na asemblerskom jeziku, korisnik na odre� enoj 
instrukcijskoj lokaciji u RAM prostoru �eli da postavi ta� ku prekida. Zahtev za ta� ku prekida se 
aktivira na host baziranom delu debugger-a, pa se adresa te instrukcije u memoriji šalje debug 
kernel-u u target-u. Debug kernel kopira instrukciju sa te lokacije na sigurno  mesto i zamenjuje 
je sa softverskom ta� kom prekida, ili trap instrukcijom. Kada izvršenje programa stigne do ta� ke 
prekida upravljanje se prenosi na debugger. Na ovaj na� in mogu� e je: a) izvršavati program 
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korak-po-korak; b) izvršavati program do ta� ke prekida bez prekida; i c) testirati softver 
kontunualno komutiraju� i izvršenje izme� u debugger-a i programa koji se testira.   
 Veoma � esto programeri �ele da debagiraju program na C ili C++, a ne na asembleru. 
Obi� no se to izvodi na slede� i na� in: Još u fazi prevo� enja programa potrebno je dozvoliti 
debugging opciju putem postavljanja (setovanja) debug switch-a. Na ovaj na� in se preko 
debugger-a i debug kernel-a definiše na kojoj � e se lokaciji ta� ka prekida postaviti u memoriji.   
 U slu� ajevima kada softverski breakpoint mehanizam nije mogu� , moraju se koristiti 
hardverski mehanizmi. Veliki broj procesora ima ugra� eno specijalne breakpoint registre koji se 
mogu direktno programirati pod softverskom kontrolom, ili preko JTAG i BDM portova. Ovi 
registri obezbe� uju jednostavnu, ali veoma efikasnu mogu� nost za debagiranje. Postavljanjem 
odgovaraju� e adrese u breakpoint registar, kada procesor pribavlja instrukciju sa te adrese, 
aktivira se breakpoint mehanizam i ulazi u debugging.    
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2. Hardverska razvojna sredstva 

 Texas Instruments nudi mnogo hardverskih i softverskih razvojnih sredstava za MSP430 
mikrokontrolere sa mikro potrošnjom i time omogu� ava procenu performansi razli� itih ure� aja, 
izradu velikog broja projekata ili pokretanje sopstvene proizvodnje bazirane na pomenutim 
mikrokontrolerima. 

 Texas Instruments razvojne plo� e se realizuju od izabranih komponenata iz familije 
MSP430 i dodatne logike za jednostavnu procenu performansi sistema i pravljenje prototipa. 
One su idealna platforma za izu� avanje nove arhitekture ili za testiranje karakteristika ure� aja.  

 2.1. Razvojna plo� a MSP430FG4618/F2013 

 Razvojna plo� a MSP430FG4618/F2013 mo�e se koristi za razvoj velikog broja 
aplikacija. MSP-EXP430FG4618 kit sadr�i razvojnu plo� u MSP430FG4618/F2013 koja je 
prikazana na slici 2.1. i dve AAA 1.5 V baterije.  

 

Slika 2.1.: Razvojna plo� a MSP430FG4618/F2013  

 Razvojna plo� a MSP430FG4618/F2013 je bazirana na Texas Instruments-ovoj MSP430 
familiji mikrokontrolera koja se karakteriše mikro potrošnjom. Na plo� i su ugra� ena dva 
mikrokontrolera: MSP430FG4618 i MSP430F2013.   
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2.1.1. Potrebni alati  

 Za unošenje i debagiranje kôda u mikrokontrolerima MSP430FG4618 i MSP430F2013 
koristimo Flash Emulation Tool (MSP-FET430UIF). To se izvodi preko dva nezavisna JTAG 
konektora. Mikrokontroler MSP430FG4618 koristi standardnu � etvoro�ilnu JTAG vezu, a 
mikrokontroler MSP430F2013 koristi Spy-Bi-wire (dvo�ilni) JTAG.  

2.1.2. Blok šema  

 Na slici 2.2. su prikazane periferne komponente razvojne plo� e MSP430FG4618/F2013.  

 

Slika 2.2.: Blok dijagram razvojne plo� e 

 Na razvojnoj plo� i se nalazi konektor za povezivanje kompatibilnih Texas Instruments 
Chipcon Wireless Evaluation Modules-a pomo� u kojih se ostvaruje be�i� na komunikacija.  

 Veze prema LCD-u, UART-u, mikrofonu, audio izlazu, bazeru i tasteru osetljivom na 
dodir omogu� avaju razvoj razli� itih aplikacija. Mo�e se ostvariti i veza izme� u dva 
mikrokontrolera koji se nalaze na plo� i. Osim toga, svi pinovi mikrokontrolera MSP430FG4618 
su dostupni za lako debagiranje preko konektora ili interfejsa. Primer kôda za ovu plo� u mo�emo  
na� i na sajtu www.ti.com/msp430. 
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2.1.3. Instalacija hardvera  

 Napajanje razvojne plo� e je izvedeno na tri na� ina: lokalno sa dve AAA baterije koje se 
nalaze na plo� i, preko Flash emulation tool-a (FET), ili spoljašnje. Izvor napajanja biramo 
razli� itim polo�ajima kratkospaja� a na konektorima VCC_1, VCC_2, i BATT. Preko konektora 
PWR1 i PWR2 dovodimo napajanje, nezavisno svakom mikrokontroleru. Slika 2.3. prikazuje 
izbor napajanja i odgovaraju� i raspored kratkospaja� a. 

 

Slika 2.3.: Podešavanja kratkospaja� a i izbor napajanja 

 Kratkospaja� em konektora BATT bira se baterijsko napajanje plo� e, nezavisno od FET-a. 
Moramo biti sigurni da je to odgovaraju� i napon za ispravan rad MSP430.   

 Kratkospaja� ima konektora VCC_1 i VCC_2 obezbe� ujemo napajanje plo� e preko FET-
ova. Ovi konektori se realizuju kao 3-pinski, po jedan za svaki mikrokontroler na plo� i. 
Konektor VCC_1 je za mikrokontroler MSP430FG4618, a konektor VCC_2 za mikrokontroler 
MSP430F2013. Kratkospaja� em u polo�aju FET biramo JTAG FET kao izvor napajanja.  

 Kratkospaja� em u polo�aju LCL dovodi se lokalno napajanje i na FET-ove, kako bi se 
obezbedili isti naponski nivoi za vreme programiranja i debagiranja.  

 Konektorima PWR1 i PWR2 dovodimo napajanje svakom mikrokontroleru. Kratkospaja�  
koji se nalazi na PWR1 obezbe� uje napajanje mikrokontrolera MSP430FG4618, a kratkospaja�  
koji se nalazi na PWR2 obezbe� uje napajanje mikrokontrolera MSP430F2013. Preko ovih 
kratkospaja� a mo�emo izmeriti potrošnju elektri� ne energije svakog mikrokontrolera. Moramo 
voditi ra� una da ne do� e do me� usobnog spoja izme� u  oba mikrokontrolera koji bi imao uticaj 
na rezultat merenja.   

 Kada izaberemo napajanje razvojna plo� a je spremna za upotrebu. Mikrokontroleri 
MSP430FG4618 i MSP430F2013 su fabri� ki programirani. Kada se dovede napajanje, 
mikrokontroler MSP430FG4618 uklju� uje sat realnog vremena sa mikro potrošnjom koji se 
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prikazuje na displeju, a mikrokontroler MSP430F2013  periodi� no uklju� uje i isklju� uje svetle� u 
diodu LED3. 

 

2.1.4. Funkcionalni pregled  

 Svetle� e diode (LED) i displej (LCD) na plo� i slu�e za vizuelnu povratnu informaciju. 
Audio aplikacije kojima je potreban kompletni tok obrade analognog signala realizujemo 
pomo� u mikrofona i audio uti� nice koji se nalaze na plo� i.  

2.1.4.1.  Interfejsi  

 Zbog uštede elektri� ne energije mo�emo isklju� iti interfejse koje ne koristimo u 
konkretnoj aplikaciji. To posti�emo konfiguracijom odre� enih pinova mikrokontrolera i/ili 
odgovaraju� im kratkospaja� ima na plo� i. (videti sliku 2.6 i tabelu 2.1, na strani 36.)   

·  4-MUX LCD 

 Na integrisanom displeju SoftBaugh SBLCDA4 LCD mogu� e je prikazati podatke koji su 
prilago� eni operacijama i vezama multipleksera 4 u 1 (4-MUX) preko LCD drajvera 
mikrokontrolera MSP430FG4618.  

·  Tasteri 

 Dva tastera, S1 i S2, koji se nalaze na plo� i su priklju� eni na digitalni ulazno/izlazni (U/I) 
port P1 mikrokontrolera MSP430FG4618, koji ima mogu� nost obrade dozvole prekida. 

·  Svetle� e diode (LED)  

 Na razvojnoj plo� i nalaze se � etiri svetle� e diode, tri povezane sa mikrokontrolerom 
MSP430FG4618 i jedna sa mikrokontrolerom MSP430F2013. Koriste se za indikaciju. Da bi 
smanjili ukupnu potrošnju energije mo�emo, pomo� u kratkospaja� a, isklju� iti dve diode.   

·  Bazer  

 Bazer je povezan na digitalni U/I port mikrokontrolera MSP430FG4618. Bazer mo�emo 
isklju� iti pomo� u kratkospaja� a JP1.  

·  Tastatura osetljiva na dodir 

 Na plo� i se nalazi kapacitivna tastatura osetljiva na dodir, koja ima oblik broja “4”. 
Tastatura je povezana na digitalni U/I port mikrokontrolera MSP430F2013. Svih 16 segmenata 
ove tastature i njihovu aktivnost kontroliše mikrokontroler MSP430F2013. Podaci se prenose do 
mikrokontrolera MSP430FG4618 preko me� usobnih veza.   
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2.1.4.2.  Komunikacioni periferni ure� aji  

 

 Razvojna plo� a podr�ava brojne komunikacione interfejse za veze na plo� i i van nje. 

·  Chipcon Wireless Evaluation Module Interfejs   

 Interfejs ka be�i� noj komunikaciji ostvarujemo preko Wireless Evaluation Module 
konektora koji podr�ava Texas Instruments-ove CCxxxxEMK module. Primopredajni moduli su 
povezani na USART konektor mikrokontrolera MSP430FG4618 koji je konfigurisan u SPI modu. 
Softverski bibliote� ki programi koji se koriste za vezu mikrokontolera MSP430 i ovih 
primopredajnika, dostupni su na www.ti.com/msp430. Modul CC2420EMK podr�ava 
802.15.4/Zigbee standard. Modul CC1100EMK mo�emo podesiti na radnu frekvenciju do 868 
MHz, a module CC2500EMK/CC2420EMK na frekvenciju 2.4 GHz.   

·  RS-232  

 Serijsku komunikaciju sa ra� unarom, mikrokontroler MSP430FG4618 ostvaruje 
standardnim RS-232 9-to pinskim konektorom preko svog USCI perifernog ure� aja koji je 
konfigurisan u UART modu. Standardna bodova brzina komunikacije se zadaje softverski.    

·  I2C/SPI  

 Mikrokontroleri MSP430FG4618 i MSP430F2013 koriste USCI i USI periferne ure� aje i 
podr�avaju I2C i SPI protokole. Protokol se koristi za me� usobnu komunikaciju mikrokontrolera 
MSP430FG4618 i MSP430F2013. Veza se mo�e prekinuti hardverski što nam omogu� ava da 
ove periferne ure� aje koristimo u druge komunikacijske svrhe. 

2.1.4.3.  Obrada analognog signala 

 Dizajn razvojne plo� e je takav da pomo� u mikrokontrolera MSP430FG4618 mo�emo 
formirati  kompletni tok obrade analognog signala. Plo� a mo�e da se koristi za brojne audio 
aplikacije. Mo�emo snimati i reprodukovati audio signale bez koriš� enja dodatnih komponenata.   
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Slika 2.4.: Tok obrade analognog signala 

·  Mikrofon  

 Mikrofon je povezan sa  mikrokontrolerom MSP430FG4618 i mo�emo ga koristiti za 
razli� ite namene. Dozvola za rad mikrofona se dobija preko odgovaraju� eg porta 
mikrokontrolera MSP430FG4618.   

·  Analogni filtri  

 Iza mikrofona se nalazi aktivni filtar prvog reda propusnik visokih u� estanosti (HPF) sa 
grani� nom frekvencijom postavljenom pribli�no na 340Hz. Filtar se koristi za eliminaciju 
ulaznih signala niskih frekvencija. Opcioni, drugi po redu, Sallen-Key aktivni filtar propusnik 
niskih u� estanosti (LPF) sa grani� nom frekvencijom postavljenom pribli�no na 4 kHz, eliminiše 
šum visokih frekvencija na analognom izlazu 12-bitnog digitalno-analognog konvertora (DAC). 
Šema filtra prikazana je na slici 2.5. Ovi filtri koriste integrisane operacione poja� ava� e koji se 
nalaze u mikrokontroleru MSP430FG4618. Operacioni poja� ava� i OA0 i OA1 obavljaju proces 
filtriranja. 
 Osen� ene oblasti na slici 2.5. prikazuju elemente koji se nalaze unutar mikrokontrolera 
MSP430FG4618.  
 



�

���
�

 
 

Slika 2.5: Šema aktivnog analognog filtra 

·  Analogni izlaz  

 Analogni izlaz je izveden na plo� i preko mono uti� nice od 3.5mm koja je povezana sa 
integrisanim operacionim poja� ava� em OA2. Ulaz u ovaj poja� ava�  mo�emo da interno 
pove�emo na DAC12 izlaz mikrokontrolera MSP430FG4618. Nekoliko opcija slabljenja je 
omogu� eno interno i hardverski pomo� u kratkospaja� a JP4. 

2.1.4.4. Sistemski taktovi 

 Razvojna plo� a ima nekoliko opcija za takt, za visoke i niske frekvencije. Svaki MSP430 
mikrokontroler ima integrisani generator takta i podršku za spoljašnje veze. 

·  Generatori  takta mikrokontrolera MSP430F2013 

 Mikrokontroler MSP430F2013 koristi interni naponski kontrolisan oscilator (VCO) koji 
radi na ~12kHz za vreme koje je potrebno da procesor u� e iz standby re�ima rada sa 
mikropotrošnjom u normalan re�im rada. Integrisani digitalno kontrolisani oscilator (DCO) je 
programabilan do frekvencije od 16MHz.  

·  Generatori  takta mikrokontrolera MSP430FG4618  

 Standardni kristal za 32.768kHz se nalazi na plo� i (podno�je X2) i on se koristi za ACLK 
mikrokontolera MSP430FG4618 za rad na niskim frekvencijama, standby re�im rada sa 
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mikropotrošnjom i RTC funkcionalnost. Integrisani FLL+ taktni modul obezbe� uje 
programabilni interni generator takta visoke frekvencije koji se koristi za pobudu CPU-a i drugih 
periferija na � ipu. Osim FLL+, mogu� e je dograditi i spoljašnji kristal do 8MHz na podno�je X1.   

2.1.4.5. Konfiguracija kratkospaja� a  

 Razvojna plo� a podr�ava rad raznih perifernih ure� aja i komponenta koje mo�emo, zbog 
smanjenja ukupne potrošnje, po potrebi isklju� iti. Ovo se ostvaruje ili softverski ili hardverski. 
Neki od kratkospaja� a su neophodni za ispravan rad plo� e.  

 

2.1.5. Polo�aj i podešavanja kratkospaja� a 

 Na slici 2.6. je prikazan polo�aj i naziv svakog kratkospaja� a na razvojnoj plo� i. 

 

Slika 2.6: Polo�aj kratkospaja� a 
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 U tabeli 2.1. su objašnjene funkcije svakog od kratkospaja� a koji je prikazan na slici 2.6. 

Tabela 2.1: Namena kratkospaja� a 

Konektor Sa kratkospaja� em Bez kratkospaja� a Potreba 

PWR1 �  Obezbe� uje napajanje 
mikrokontrolera 
MSP430FG4618. 
 

�  Tako� e se koristi za 
merenje potrošnje 
elektri� ne energije 
mikrokontrolera 
MSP430FG4618. 

Mikrokontroler 
MSP430FG4618 je 
isklju� en 

Neophodan je za rad 
MSP430FG4618 

PWR2 �  Obezbe� uje napajanje 
mikrokontrolera 
MSP430F2013. 
 

�  Tako� e se koristi za 
merenje potrošnje 
elektri� ne energije za 
MSP430F2013. 

MSP430F2013 je 
isklju� en 

Neophodan je za rad 
MSP430F2013 

BATT �  Baterije se koriste za 
napajanje. 
 

�  Tako� e se koristi za 
merenje potrošnje 
elektri� ne energije. 

MSP430 se ne napaja 
sa baterija. 

Neophodan je za rad sa 
AAA baterijama 

JP1 �  Bazer priklju� en na pin 
P3.5 mikrokontrolera 
MSP430FG4618 

Bazer je u MUTE 
re�imu rada 

Opcioni 

JP2 �  LED3 priklju� ena na 
P1.0 mikrokontrolera  
MSP430F2013 

LED3 je otka� ena Opcioni / Potreban za 
rad LED3 

JP3 �  LED4 priklju� ena na 
P5.1 mikrokontrolera 
MSP430FG4618 

LED4 je otka� ena Opcioni / Potreban za 
rad LED4 

JP4 �  Slabljenje audio izlaza 98% slabljenja DAC12 Opcioni 
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digitalo-analognog 
konvertora DAC12 je 
postavljeno pribli�no 
na 69% 

audio izlaza 

Konektor 
H1 
(Pinovi 1-2, 
3-4) 

�  I2C konfiguracija 
1-2: SDA - UCB0SDA 
3-4: SCL - UCB0SCL 

Nije mogu� a 
komunikacija preko 
I2C 

Neophodan za 
me� usobnu 
komunikaciju  dva 
mikrokontolera na plo� i 

Konektor 
H1 
(Pinovi 1-2, 
3-4, 5-6, 7-8) 

�  SPI konfiguracija 
1-2: SDI – UCB0SIMO 
3-4: SDO – UCB0SOMI 
5-6: P1.4 – P3.0 (CS) 
7-8: SCLK – UCB0CLK 

Nije mogu� a 
komunikacija preko 
SPI 

Neophodan za 
me� usobnu 
komunikaciju  dva 
mikrokontolera na plo� i 
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2.1.6. Šema MSP430FG4618/F2013 razvojne plo� e 
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3. Softverska razvojna sredstva 
 

 3.1. IAR Embedded Workbench IDE 

 IAR Embedded Workbench IDE je radno okru�enje u kome su integrisani svi potrebni 
alati: C/C++ kompajler, asembler, IAR XLINK linker, IAR XAR kreator biblioteke, IAR XLIB 
Librarian, editor, projekt menad�er sa dodatkom za komandu Make, dodatak za komandnu liniju 
i IAR C-SPY® debugger, debugger za više programske jezike.  

 IAR Embedded Workbench IDE sadr�i sve alate koji su potrebni za uspešan projekat, ali 
mo�emo integrisati i druge alate. IAR Embedded Workbench IDE mo�emo lako prilagoditi za rad 
sa omiljenim editorom i sistemom za upravljanje izvornim kôdom (source code control system).  
 Kompajler, asembler i linker je mogu� e pokrenuti i iz okru�enja sa linijskim editorom 
komandi, ako �elimo da ih koristimo kao eksterne alate u ve�  utvr� enom projektnom okru�enju. 
 

 3.1.1. Programiranje mikrokontrolera serije MSP430 na razvojnoj plo� i      
  MSP430FG4618/F2013 

 Programiranje mikrokontrolera serije MSP430 na razvojnoj plo� i MSP430FG4618/F2013 
se obavlja u par, prili� no standardnih koraka. U našem slu� aju, kao programator, koristi� emo 
Flash Emulation Tool MSP-FET430UIF. Kao što se mo�e videti na slici 3.1., MSP-FET430UIF 
kao konektore sa jedne strane ima USB koji se priklju� uje na ra� unar, a sa druge strane JTAG 
konektor koji se priklju� uje na JTAG konektor odgovaraju� eg mikrokontrolera na razvojnoj 
plo� i. 

 

Slika 3.1. Flash Emulation Tool MSP-FET430UIF 
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  3.1.1.1. Programiranje mikrokontrolera MSP430FG4618  

 

1. Pove�imo USB konektor MSP-FET430UIF-a na ra� unar. 
2. Pove�imo JTAG konektor MSP-FET430UIF-a na JTAG1 konektor koji se nalazi na razvojnoj 
plo� i.   
3. Kreirajmo novi projekat ili u� itajmo postoje� i projekat u IAR Embedded Workbench-u.    
4. U padaju� em meniju Project, IAR Embedded Workbench-a, izaberimo Options; pojavi� e se 
meni koji je prikazan na slici 3.2. U General Options, pod Target izaberimo MSP430FG4618 iz 
MSP430x4xx Family opcija.   
 

 
 

Slika 3.2: Izbor ure� aja u IAR-u 
 

5. U Debugger opcijama, iz istog menija, izaberimo FET Debugger kao što je prikazano na slici  
3.3.   
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Slika 3.3: Selektovanje FET Debugger-a 
 

6. U opcijama FET Debugger-a izaberimo Texas Instrument USB-IF kao što je prikazano na slici 
3.4. Nema potrebe da menjamo polaznu Automatic postavku.  
 

 
 

Slika 3.4: Izbor USB interfejsa 
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  3.1.1.2. Programiranje mikrokontrolera MSP430F2013  
 

1. Pove�imo 14-o pinski kabal na JTAG2 konektor koji se nalazi na plo� i.   
2. Kreirajmo novi projekat ili u� itajmo postoje� i projekat u IAR Embedded Workbench-u.    
3. U padaju� em meniju Project, IAR Embedded Workbench-a, izaberimo Options; pojavi� e se 
meni koji je prikazan na slici 3.2. U General Options, pod Target izaberimo MSP430F2013 iz 
MSP430x2xx Family opcija.  
4. U Debugger opcijama, iz istog menija, izaberimo FET Debugger kao što je prikazano na slici  
3.3.   
5. U opcijama FET Debugger-a izaberimo Texas Instrument USB-IF kao što je prikazano na slici 
3.4.  
Nema potrebe da menjamo polaznu Automatic postavku.  
6. Za novo-kreirani projekat, Spy-Bi-Wire interfejs je polazna postavka za MSP430F2013.  Ako 
je potrebno da tu postavku promenimo, u FET Debugger meniju � ekirajmo Override default i 
zatim izaberimo Spy-Bi-Wire umesto 4-Wire JTAG, kao što je prikazano na slici 3.5. Paralelni 
FET ne podr�ava Spy-Bi-Wire interfejs i ne mo�e da se koristi za debagiranje/programiranje 
MSP430F2013.   

 

 
 

Slika 3.5: Izbor Spy-Bi-Wire interfejsa za MSP430F2013 
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3.1.2. Instalirani fajlovi 

 3.1.2.1. Struktura direktorijuma  

 Tokom instalacije kreiraju se direktorijumi koji sadr�e razli� ite tipove fajlova koji se 
koriste u IAR Systems razvojnim alatima. 

3.1.2.1.1. Osnovni direktorijum 

 Osnovni direktorijum koji se kreira prilikom instalacije je x:\Program Files\IAR 
Systems\Embedded Workbench 4.n\ direktorijum , gde je sa x ozna� ena particija 
na kojoj je instaliran Microsoft Windows, a  4.n  je broj verzije IAR Embedded Workbench IDE-
a. 

 

Slika 3.6: Struktura direktorijuma 

Napomena: Instalacioni put mo�e da se razlikuje od ovoga prikazanog na slici što zavisi od 
prethodno instaliranih IAR proizvoda, i od našeg izbora. 

 

 3.1.2.2. Tipovi fajlova 

 MSP430 verzija IAR Systems razvojnih alata koristi slede� e standardne ekstenzije za 
specifi� ne IAR tipove fajlova:  
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Tabela 3.1: Tipovi fajlova 

 

Ekstenzija Tip fajla Izlaz iz  Ulaz u 

a43 Ciljna aplikacija XLINK-a EPROM, C-SPY, i sl. 

asm  Asemblerski izvorni kôd Tekst editora Asembler 

c  C izvorni kôd Tekst editora Kompajler 

Cfg Syntax coloring configuration Tekst editora IAR Embedded 
Workbench 

cpp  Embedded C++ izvorni kôd Tekst editora Kompajler 

d43 Ciljna aplikacija sa informacijama za 
debagiranje 

XLINK-a  C-SPY i druge debugger-
e simbola 

Dbg Ciljna aplikacija sa informacijama za 
debagiranje 

XLINK-a  C-SPY i druge debugger-
e simbola 

Dbgt Podešavanje desktopa debugger-a C-SPY-a C-SPY 

ddf  Opisni fajl ure� aja Tekst editora C-SPY 

Dep Dependency informacije IAR Embedded 
Workbench-a 

IAR Embedded  
Workbench 

dni  Fajl za inicijalizaciju debugger-a C-SPY-a C-SPY 

Ewd Projektna podešavanja za C-SPY IAR Embedded 
Workbench-a 

IAR Embedded  
Workbench 

Ewp IAR Embedded Workbench projekat 
(trenutna verzija) 

IAR Embedded  
Workbench-a 

IAR Embedded 
Workbench 

Eww Fajl radnog prostora IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

Fmt Informacije o formatiranju za Locals i 
Watch prozore 

IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

h  C/C++ ili asemblerski header fajl Tekst editora Kompajler ili asembler  
#include 

i  Preprocesorski izvorni fajl Kompajlera Kompajler 

inc  Izvorni kôd asemblerskog zaglavlja Tekst editora Asembler #include 
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lst  List izlaz Kompajlera i 
asemblera 

 – 

mac C-SPY definicije makroa Tekst editora C-SPY 

map List izlaz XLINK-a – 

pbd Source browse informacija IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

Pbi Source browse informacija IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

pew IAR Embedded Workbench projekat 
(stari projektni format) 

IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

prj IAR Embedded Workbench projekat 
(stari projektni format) 

IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

r43 Objektni modul Kompajlera i 
asemblera 

XLINK, XAR, i XLIB 

s43 MSP430 asemblerski izvorni kôd Tekst editora MSP430 IAR Asembler 

sfr Definicije registara specijalne namene Tekst editora C-SPY 

wsdt Podešavanje desktopa radnog 
prostora 

IAR Embedded 
Workbench-a 

IAR Embedded 
Workbench 

xcl  Proširena komandna linija Tekst editora Asembler, kompajler, 
XLINK 

xlb Komanda proširenog bibliote� kog 
komandnog fajla 

Tekst editora XLIB 

  

 Polaznu ekstenziju mo�emo promeniti tako što � emo, kada upisujemo naziv fajla, upisati 
i ekstenziju. 

 Fajlovi sa ekstenzijama ini  i dni  se kreiraju dinami� ki kada pokrenemo IAR Embedded 
Workbench alate. Ovi fajlovi, koji sadr�e informacije o konfiguraciji našeg projekta i drugim 
podešavanjima, nalaze se u settings direktorijumu projektnog direktorijuma. 

  

3.1.2.3. Dokumentacija 

 Preporu� ljivo je pro� itati readme.htm  fajl zbog informacija koje mo�da nisu sadr�ane 
u priru� nicima. Ovaj fajl se nalazi u 430\doc  direktorijumu. 
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  3.1.2.3.1. Priru� nici i uputstva 

 Priru� nici i uputstva za IAR Embedded Workbench su slede� i: 

·  MSP430 IAR Embedded Workbench® IDE User Guide 
·  MSP430 IAR C/C++ Compiler Reference Guide 
·  MSP430 IAR Assembler Reference Guide 
·  IAR Linker and Library Tools Reference Guide 
·  DLIB Library Reference information 
·  CLIB Library Reference Guide 
·  IAR Embedded Workbench® MISRA C Reference Guide 

   

  3.1.2.3.2. Online pomo�  

 Online pomo�  sadr�i informacije o menijima i dijalog prozorima iz IAR Embedded 
Workbench IDE-a. Tu mo�emo na� i i informacije o funkcijama DLIB biblioteka. Da bismo 
dobili informacije o funkciji, selektujmo naziv funkcije u editor prozoru i pritisnimo F1. 

Napomena: Ako selektujemo naziv funkcije u editor prozoru i pritisnemo F1 dok koristimo CLIB 
biblioteku, dobi� emo informacije za DLIB biblioteku. 

  3.1.2.3.3. IAR na internetu 

 Najnovije informacije iz IAR Systems-a mo�emo na� i na sajtu www.iar.com, � ija adresa 
se nalazi i u Help meniju Embedded Workbench IDE-a. 

  

 3.1.3. Pokretanje IAR Embedded Workbench IDE-a  

 Kliknimo na Start dugme na taskbar-u i izaberimo All Programs > IAR Systems > IAR 
Embedded Workbench for MSP430 V3 > IAR Embedded Workbench.  

 Fajl IarIdePm.exe je smešten u common\bin  direktorijumu u našoj IAR instalaciji, za 
slu� aj da �elimo da pokrenemo program iz komandne linije ili iz Windows Explorer-a. 

  3.1.3.1. Dupli klik na fajl radnog prostora  

 Fajl radnog prostora ima ekstenziju eww. Duplim klikom na taj fajl pokre� emo IAR 
Embedded Workbench IDE. Ako imamo instalirano nekoliko verzija IAR Embedded Workbench-
a, fajl radnog prostora � e biti otvoren zadnje koriš� enom verzijom IAR Embedded Workbench-a 
koji koristi taj tip fajla. 
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 3.1.4. Izlazak iz programa 

 Da bismo izašli iz IAR Embedded Workbench IDE-a, izaberimo File > Exit. Bi� e nam 
postavljena pitanja da li �elimo da sa� uvamo promene u editor prozorima, projektima i radnim 
prostorima pre nego što ih zatvorimo. 

  

 3.1.5. Organizovanje prozora na ekranu 

 U IAR Embedded Workbench IDE-u, mo�emo rasporediti prozore i organizovati ih po 
�elji.  
 Svaki put kada otvorimo prethodno sa� uvan radni prostor, isti prozori � e se otvoriti, i 
ima� e istu veli� inu i polo�aj. 
 Svaki prozor koji otvorimo ima svoju polaznu poziciju koja zavisi od drugih trenutno 
otvorenih prozora. Svaki prozor mo�e biti zaklju� an (nepokretan) ili slobodan. 
 
 Zaklju� an prozor nalazi se na odre� enom mestu, koje odredimo, u osnovnom prozoru 
Embedded Workbench-a. Da bismo zadr�ali mnogo prozora otvorenih u isto vreme, mo�emo ih 
organizovati u grupe u tab polju. Ovo zna� i da koristimo jedan deo ekrana za nekoliko trenutno 
otvorenih prozora. Tako� e, lako mo�emo menjati veli� ine prozora. Ako se menja veli� ina jednog 
zaklju� anog prozora, veli� ine ostalih zaklju� anih prozora � e se prilagoditi tome. 
 
 Slobodni prozor je uvek ispred ostalih prozora. Njegov polo�aj i veli� ina ne uti� u na 
druge trenutno otvorene prozore. Slobodni prozor mo�emo pomeriti na bilo koje mesto na 
ekranu, a tako� e i van osnovnog prozora IAR Embedded Workbench IDE. 
 Da bismo jedan prozor u� inili slobodnim, kliknimo duplim klikom na naslovnu traku tog 
prozora.  
 
Napomena: Editor prozor je uvek zaklju� an. Kada otvorimo editor prozor, njegov polo�aj se 
odre� uje automatski u zavisnosti od drugih trenutno otvorenih prozora.  

  

 3.1.6. IAR Embedded Workbench IDE prozor 

 Na slici 3.7. je prikazan IAR Embedded Workbench IDE prozor sa razli� itim 
komponentama. 
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Slika 3.7: IAR Embedded Workbench IDE prozor 

Prozor mo�e izgledati druga� ije u zavisnosti od toga koji se dodatni alati koriste. 

  3.1.6.1. Meni bar 

 Iz meni bara mo�emo pristupiti IAR Embedded Workbench IDE menijima. 

Tabela 3.2: IAR Embedded Workbench IDE meni bar 

Meni Opis 

File File meni sadr�i komande za otvaranje izvornih i projektnih fajlova, � uvanje i 
štampanje, i izlazak iz programa IAR Embedded Workbench IDE-a. 

Edit Edit meni sadr�i komande za editovanje i pretragu u prozorima editora i za 
dozvolu i zabranu upotrebe ta� aka prekida u C-SPY-u. 

View Komande u View meniju slu�e za otvaranje prozora i za odabir toolbar-ova koji 
� e biti prikazani. 

Project U Project meniju se nalaze komande za dodavanje fajlova projektu, kreiranje 
grupa i pokretanje IAR Systems alata u trenutnom projektu. 

Tools Tools meni konfiguriše korisnik tako što dodaje alate koji se koriste sa IAR 
Embedded Workbench IDE-om. 

Window Komandama iz Window menija mogu da se podešavaju IAR Embedded 
Workbench IDE prozori i da se menja njihov raspored na ekranu. 

Help Komandama iz Help menija dobijamo pomo�  oko IAR Embedded Workbench 
IDE-a. 
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  3.1.6.2. Tool b a r 

 IAR Embedded Workbench IDE toolbar (dostupan iz View menija) sadr�i ikonice za 
naj� eš� e koriš� ene komande iz IAR Embedded Workbench IDE menija, i polje za unos teksta gde 
mo�emo ukucati re�  za brzu pretragu. 
 Objašnjenje za bilo koju ikonicu � e se pojaviti ako strelicom miša poka�emo na ikonicu. 
Kada komanda nije na raspolaganju, odgovaraju� a ikonica u toolbar-u je zatamnjena i ne 
mo�emo da kliknemo na nju.  
 
 Na slici 3.8. se vide komande koje odgovaraju svakoj ikonici iz toolbar-a: 

 

Slika 3.8: IAR Embedded Workbench IDE toolbar 

Tabela 3.3: Opis komandi koje odgovaraju svakoj ikonici iz toolbar-a: 

Komanda Opis 
New Prikazuje podmeni sa komandama za kreiranje 

novog radnog prostora ili novog tekstualnog fajla 
Open 

Standardne Windows komande Save 
Save All 
Print Prikazuje dijalog prozor iz koga mo�emo da 

štampamo tekstualni dokument 
Cut  

Standardne Windows komande 
Copy 
Paste  
Undo 
Redo 
Quick search text box Polje za unos teksta za brzu pretragu 
Find Next 

Standardne Windows komande 
Find 
Replace 
Go to 
Toggle Bookmark Uklju� uje/isklju� uje bookmark 
Next Bookmark Prelazi na slede� i bookmark 
Navigate Backward Pretra�ivanje unazad u istoriji ta� ke umetanja 
Navigate Forward Pretra�ivanje unapred u istoriji ta� ke umetanja 
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Compile Kompajlira i asemblira trenutno aktivni fajl. 
Make A�urira izvršni program kompajliranjem, 

asembliranjem i linkovanjem samo fajlova koji su 
promenjeni od zadnjeg koriš� enja naredbe Make.  

Stop Build Stopira trenutnu operaciju gra� enja. 
Toggle Breakpoint Prebacuje ta� ku prekida na naredbu ili instrukciju 

koja sadr�i ili je blizu kursora u prozoru izvornog 
kôda. 

Debug Pokre� e IAR C-SPY Debugger da bismo mogli da 
debagiramo objektne fajlove projekta. 

�

  3.1.6.3. Status bar 

 Status bar u donjem delu prozora (dostupan iz View menija) prikazuje status IAR 
Embedded Workbench IDE-a i stanje tastera za promenu. 
 U toku editovanja, status bar prikazuje broj trenutne linije i kolone koja sadr�i ta� ku 
umetanja, i statuse Caps Lock, Num Lock, i Overwrite. 

 

Slika 3.9: Status bar IAR Embedded Workbench IDE prozora  

 

 3.1.7. Radni prozor (Workspace prozor) 

 Radni prozor je prozor u kome pristupamo projektima i fajlovima tokom razvoja 
aplikacije. 
 Radni prozor, dostupan iz View menija, prikazuje naziv trenutnog radnog prostora i stablo 
projekata, grupa i fajlova uklju� enih u radni prostor. 
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Slika 3.10: Radni prozor 

 U padaju� em meniju, koji se nalazi na vrhu prozora, biramo konfiguraciju gra� enja koja 
� e biti prikazana u prozoru za odre� eni projekat. 

 Kolona koja sadr�i statusne informacije o podešavanjima i dopisivanjima mo�e imati 
jednu od tri ikonice za svaki nivo u projektu: 

Tabela 3.4. Ikonice za indikaciju podešavanja/dopisivanja 

Prazno Nema podešavanja/dopisivanja za ovaj fajl/grupu 
Crni kontrolni znak Postoje lokalna podešavanja/dopisivanja za ovaj fajl/grupu 
Crveni kontrolni znak Postoje lokalna podešavanja/dopisivanja za ovaj fajl/grupu, ali su 

identi� na prethodnim podešavanjima, što zna� i da su dopisivanja suvišna. 

 U dnu prozora biramo koji � e projekat biti prikazan. Mo�emo izabrati i prikaz 
celokupnog radnog prostora.  

  3.1.7.1. Kontekst meni radnog prozora 

 Desnim klikom bilo gde u radnom prozoru prikazuje se kontekst meni koji sadr�i 
nekoliko komandi. 
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Slika 3.11: Kontekst meni radnog prozora 

 Kontekst meni sadr�i slede� e komande: 

Tabela 3.5: Komande iz kontekst menija radnog prozora 
 

Komanda iz menija Opis 

Options Prikazuje dijalog prozor u kome je mogu� e promeniti podešavanja za 
svaki alat za gra� enje na nivou celog projekta, grupe fajlova ili na 
nivou svakog pojedina� nog fajla. 

Make A�urira izvršni program kompajliranjem, asembliranjem i 
linkovanjem samo fajlova koji su promenjeni od zadnjeg koriš� enja 
naredbe Make. 

Compile Kompajlira i asemblira trenutno aktivni fajl. Fajl biramo ili 
selektovanjem u radnom prozoru, ili selektovanjem editor prozora 
koji sadr�i fajl koji �elimo da kompajliramo. 

Rebuild All Rekompajlira i relinkuje sve fajlove u izabranoj konfiguraciji 
gra� enja. 

Clean Briše me� u fajlove. 
Stop Build Stopira trenutnu operaciju gra� enja. 
Add>Add Files Otvara dijalog prozor gde se mogu dodati fajlovi projektu. 
Add>Add 
"filename" 

Dodaje nazna� eni fajl projektu. Ova komanda je dostupna jedino ako 
postoji otvoren fajl u editoru. 

Add>Add Group Otvara dijalog prozor u kome se mogu dodati nove grupe projektu. 
Remove Uklanja selektovanu stavku iz radnog prozora. 
Source Code 
Control 

Otvara podmeni sa komandama za upravljanje izvornim kôdom. 

File 
Properties 

Otvara standardni File Properties dijalog prozor za selektovani fajl. 

Set as Active Aktivira odabrani projekat. Aktivni projekat se bilduje kada se izvrši 
Make naredba. 

�
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  3.1.7.2. Source Code Control meni (meni za upravljanje izvornim kôdom)  
 

 Source Code Control (SCC) meni je dostupan iz Project menija i iz kontekst menija u 
radnom prozoru. Ovaj meni sadr�i neke od naj� eš� e koriš� enih komandi. 

 

 

Slika 3.12: Source Code Control meni 

 Kontekst meni sadr�i slede� e komande: 

 
Tabela 3.6: Opis Source Code Control komandi 
 

Komanda Opis 

Check In Otvara Check In Files dijalog prozor gde biramo fajlove za check in. Bilo 
koja promena koju napravimo u fajlovima bi� e sa� uvana u arhivi. 
Komandu je mogu� e izvršiti kada su checked-out fajlovi selektovani u 
radnom prozoru. 

Check Out U zavisnosti od toga koji SCC sistem koristimo, mo�e se pojaviti dijalog 
prozor. Ovom komandom dobijamo lokalnu kopiju fajla (fajlova), koju 
mo�emo editovati. Komandu je mogu� e izvršiti kada su checked-in fajlovi 
selektovani u radnom prozoru. 

Undo Check 
out 

Selektovani fajl se vra� a na poslednju sa� uvanu verziju. Bilo kakva 
promena koju smo napravili u fajlovima bi� e izgubljena. Komandu je 
mogu� e izvršiti kada su checked-out fajlovi selektovani u radnom 
prozoru. 

Get Latest 
Version 

Menja selektovani fajl poslednjom sa� uvanom verzijom. 

Compare Prikazuje, u posebnom SCC prozoru, razliku izme� u trenutne verzije i 
poslednje sa� uvane verzije. 

History Prikazuje SCC-specifi� ne informacije o istoriji kontrole selektovanog 
fajla. 
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Properties Prikazuje informacije dostupne u SCC sistemu za selektovani fajl. 
Refresh A�urira prikazani SCC status za sve fajlove koji su deo projekta. 

Komandu je mogu� e izvršiti za sve projekte pod SCC-om. 
Add 
Project To 
Source 
Control 

Otvara dijalog prozor, koji poti� e iz SCC aplikacije tipa klijent, i 
omogu� ava kreiranje veze izme� u selektovanog IAR Embedded 
Workbench projekta i SCC projekta; IAR Embedded Workbench projekat 
� e tada biti SCC-kontrolisani projekat. Nakon kreiranja ove veze u 
radnom prozoru � e se pojaviti specijalna kolona  koja sadr�i statusne 
informacije. 

Remove 
Project 
From 
Source 
Control 

Uklanja vezu izme� u selektovanog IAR Embedded Workbench projekta i 
SCC projekta; projekat više ne� e biti SCC-kontrolisan. Kolona u radnom 
prozoru koja sadr�i informacije o SCC statusu ne� e više biti vidljiva za taj 
projekat. 

�

 3.1.8. Editor prozor 

 U editor prozoru su prikazani izvorni fajlovi. U isto vreme mo�e biti otvoreno nekoliko 
ovakvih prozora. 

 

Slika 3.13: Editor prozor 

 Naziv otvorenog izvornog fajla je prikazan u tab polju. Ako je fajl samo za � itanje bez 
dozvole menjanja (read-only), u donjem levom uglu editor prozora se vidi ikonica u obliku 
katanca. Ako je fajl izmenjen nakon što je poslednji put sa� uvan, pojavi� e se zvezdica u tab polju 
posle naziva fajla, na primer Utilities.c * . Padaju� i meni koji se nalazi u gornjem desnom 
uglu editor prozora sadr�i sve otvorene fajlove. 
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  3.1.8.1. Split komande (komande za deljenje) 

 Da bismo podelili editor prozor horizontalno ili vertikalno na više delova koristimo 
Window > Split command ili Splitter controls. 

 Window meni sadr�i komande za otvaranje višestrukih editor prozora, kao i komande za 
premeštanje fajlova iz razli� itih editor prozora. 

  3.1.8.2. Go to function 

 Pomo� u Go to function ikonice koja se nalazi u donjem levom uglu editor prozora mogu 
da se prika�u sve funkcije u C ili C++  prozoru editora. To su direktne pre� ice za neku od njih. 

  3.1.8.3. Kontekst meni tab polja editor prozora  

 Kontekst meni, koji se pojavi kada kliknemo desnim klikom na tab polje u editor prozoru, 
sadr�i komande za � uvanje i zatvaranje fajla. 

 

Slika 3.14: Kontekst meni tab polja editor prozora 

   

  3.1.8.4. Kontekst meni editor prozora 

 

Slika 3.15: Kontekst meni editor prozora 
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Napomena: Sadr�aj ovog menija zavisi od razli� itih okolnosti, što zna� i da mo�e imati druge 
komande u pore� enju sa slikom.  

 Kontekst meni editor prozora sadr�i slede� e komande: 

Tabela 3.7: Opis komandi iz kontekst menija editor prozora 
 

Komanda Opis 

Cut, Copy, Paste Standardne komande. 

Complete Pokušava da završi re�  koju smo po� eli da kucamo, baziraju� i 
svoju predpostavku na sadr�aju ostalog dela dokumenta. 

Match Brackets Selektuje tekst izme� u zagrada i obuhvata ta� ku umetanja, 
pove� ava selekciju do slede� eg po veli� ini para zagrada, ili 
daje zvu� ni signal ako nema ve� eg para zagrada. 

Insert Template Prikazuje listu u editor prozoru iz koje mo�emo izabrati kôdni 
šablon koji se ubacuje na mesto ta� ke umetanja. Ako    
izabrani kodni šablon zahteva bilo kakvo ulazno polje, 
pojavi� e se Template dijalog prozor. 

Open "header.h" Otvara header fajl "�K�H�D�G�H�U���K" u editor prozoru. Ova 
komanda je dostupna jedino ako je, kada otvorimo kontekst 

meni, ta� ka umetanja smeštena u  ���L�Q�F�O�X�G�H liniji.  

Open Header/Source 
File  

Prelazi sa trenutnog fajla na odgovaraju� i header ili izvorni 
fajl. Ako odredišni fajl nije otvoren kada se izvršava 
komanda, prvo � e biti otvoren. Ova komanda je dostupna 
jedino ako je, kada otvorimo kontekst meni, ta� ka umetanja 

smeštena u bilo koju drugu liniju osim u ���L�Q�F�O�X�G�H. Ova 
komanda se nalazi i u  File > Open meniju. 

Go to definition Prikazuje deklaraciju simbola gde je smeštena ta� ka 
umetanja. 

Check In 
Check Out 
Undo Checkout 

Komande za upravljanje izvornim kôdom (SCC). Ove 
komande su dostupne samo ako je trenutni izvorni fajl u 
editor prozoru SCC-kontrolisan. Fajl tako� e mora biti deo 
trenutnog projekta. 

Toggle Breakpoint  
(Code)  

Prebacuje code  ta� ku prekida na naredbu ili instrukciju koja 
sadr�i ili je blizu kursora u prozoru izvornog kôda.  

Toggle Breakpoint 
(Log) 

Prebacuje log  ta� ku prekida na naredbu ili instrukciju koja 
sadr�i ili je blizu kursora u prozoru izvornog kôda. 
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Enable/disable 
Breakpoint 

Prebacuje ta� ku prekida iz stanja isklju� ena, ali ne stvarno 
uklonjena (dostupna je za kasniju upotrebu), u ponovo 
uklju� ena. 

Set Next Statement Postavlja PC (program counter (programski broja� )) direktno 
na selektovanu naredbu ili instrukciju bez izvršavanja bilo 
kog kôda. Ovu komandu treba koristiti oprezno. Komanda je 
dostupna samo kad se koristi debugger. 

Quick Watch Otvara Quick Watch prozor. Komanda je dostupna samo kad 
se koristi debugger. 

Add to Watch Dodaje odabrani simbol Watch prozoru. Komanda je 
dostupna samo kad se koristi debugger. 

Move to PC Pomera ta� ku umetanja na trenutnu poziciju PC-a u editor 
prozoru. Komanda je dostupna samo kad se koristi debugger. 

Run to Cursor Izvršava program od trenutne naredbe ili instrukcije do 
selektovane naredbe ili instrukcije. Komanda je dostupna 
samo kad se koristi debugger. 

Options Prikazuje IDE Options dijalog prozor. 
�

 
   
  3.1.8.5. Kratak pregled koriš� enja tastera u editoru 
 
 U slede� im tabelama je dat pregled komandi editora koje se unose sa tastature. 
 
Koristimo slede� e tastere i kombinaciju tastera za pomeranje ta� ke umetanja: 
 
 
Tabela 3.8: Komande za pomeranje ta� ke umetanja, koje se unose sa tastature 
 

Za pomeranje ta� ke umetanja Pritisnimo 

Jedan karakter levo Levu strelicu 

Jedan karakter desno Desnu strelicu 

Jednu re�  levo Ctrl+Levu strelicu 

Jednu re�  desno Ctrl+Desnu strelicu 

Jednu liniju gore Strelicu gore 

Jednu liniju dole Strelicu dole 

Na po� etak linije Home 

Na kraj linije End 
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Na prvu liniju u fajlu Ctrl+Home 

Na zadnju liniju u fajlu Ctrl+End 
    
 Koristimo slede� e tastere i kombinaciju tastera za skrolovanje teksta: 
 
 
Table 3.9: Komande za skrolovanje,  koje se unose sa tastature 
 

Da skrolujemo Pritisnimo 

Jednu liniju na gore Ctrl+ Strelicu gore 

Jednu liniju na dole   Ctrl+ Strelicu dole 

Jednu stranicu gore Page Up 

Jednu stranicu dole Page Down 

            
 

 Koristimo slede� e kombinacije tastera za selektovanje teksta: 
 
 
Table 3.10: Komande za selektovanje teksta, koje se unose sa tastature 
 

Da selektujemo Pritisnimo 

Karakter na levo Shift+ Levu strelicu 

Karakter na desno Shift+ Desnu strelicu 

Jednu re�  na levo Shift+Ctrl+ Levu strelicu 

Jednu re�  na desno   Shift+Ctrl+ Desnu strelicu 

Do iste pozicije u prethodnoj liniji Shift+ Strelicu gore 

Do iste pozicije u narednoj liniji Shift+ Strelicu dole 

Do po� etka linije Shift+Home 

Do kraja linije Shift+End 

One screen up Shift+Page Up 

One screen down Shift+Page Down 

Do po� etka fajla Shift+Ctrl+Home 

Do kraja fajla Shift+Ctrl+End 
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 3.1.9. Source Browser prozor 

 U Source Browser prozoru, dostupnom iz View menija, prikazan je spisak svih simbola, u 
aktivnoj konfiguraciji gra� enja, pore� an po abecednom redu. 

 

Slika 3.16: Source Browser prozor 

 Prozor se sastoji od dva odvojena dela. U gornjem delu su prikazani nazivi simbola i 
funkcija  iz projekta. 
 Na po� etku svake vrste nalazi se ikonica koja koja odgovara Symbol type klasifikaciji. 
Klikom na zaglavlje prozora simboli se sortiraju po nazivu ili po tipu. 

 Iz gornjeg dela prozora mo�emo pristupiti i kontekst meniju.  

 Za simbol selektovan u gornjem delu, u donjem delu se prikazuju slede� e informacije:  

Tabela 3.11: Informacije u Source Browser prozoru 

Tip informacije Opis 

Pun naziv (Full name)  Prikazuje jedinstveno ime svakog elementa, na primer  
classname::membername. 

Tip simbola (Symbol type) Prikazuje tip simbola za svaki element: enumeration, enumeration 
constant, class, typedef, union, macro, field ili  variable, function, 
template function, template class, i configuration. 

Naziv fajla (Filename) Navodi put do fajla u kome je definisan element. 
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 3.1.10. Ure� ivanje IDE-a 
 
 Da bismo IDE prilagodili svojim potrebama, izaberimo Tools > Options. Tu se nalazi 
veliki broj komandi za: 
�  Konfigurisanje editora 
�  Konfigurisanje boja i fontova u editoru 
�  Konfigurisanje project build komande 
�  Organizovanje prozora u C-SPY-u 
�  Koriš� enje eksternog editora 
�  Promenu fontova 
�  Promenu klju� eva povezivanja 
�  Podešavanje koli� ine izlaznih podataka u Messages prozoru. 
 
 Osim toga, mo�emo pove� ati broj prepoznatljivih ekstenzija fajlova. Po definiciji, svaki 
od alata za gra� enje prihvata set standardnih ekstenzija. Da bismo promenili taj set, izaberimo 
Tools > Filename Extensions. 
 
 3.1.11. Komunikacija sa eksternim alatima 
 
 Tools meniju mo�emo dodati eksterne alate da bismo im lakše pristupili iz IAR 
Embedded Workbench IDE-a. Zbog toga, Tools meni mo�e izgledati druga� ije u zavisnosti od 
toga koje alate smo dodali. 
 Da bismo meniju dodali eksterni alat, izaberimo Tools > Configure Tools da otvorimo 
Configure Tools dijalog prozor. 

 
 

Slika 3.17: Configure Tools dijalog prozor 
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 Nakon što dodamo odgovaraju� u informaciju i kliknemo OK, komanda koju smo 
nazna� ili � e se pojaviti u Tools meniju.  
 

 
 

Slika 3.18: Prilago� eni Tools meni 
 

 
   
  3.1.11.1. Dodavanje komandi iz komandne linije 
 
 Komande iz komandne linije i pozive komandnih (batch)  fajlova pokre� emo sa konzole. 
�
 Mo�emo dodati komande iz komandne linije Tools meniju i izvršavati ih odatle 
koriš� enjem slede� ih koraka:  
 
1. Da bismo dodali komande Tools meniju, moramo da nazna� imo odgovaraju� u konzolu. 
Ukucajmo jednu od slede� ih konzola u Command polje za unos teksta: 
 
 
 
Tabela 3.12: Konzole 
 

Sistem Konzola 

Windows 98/Me command.com 

Windows NT/2000/XP cmd.exe (preporu� eno) ili command.com 

   

2. Upišimo naziv komande iz komandne linije ili komandnog fajla u Argument polje za unos 
teksta. 

Argument tekst treba da bude naveden kao: 

/C name 

gde je name naziv komande ili  komandnog fajla koji �elimo da pokrenemo.  

/C opcija zatvara konzolu nakon izvršenja. 
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 Primer: 

 Da bismo Tools meniju dodali komandu Backup za pravljenje kopije celokupnog project 
direktorijuma na mre�ni disk, treba da nazna� imo Command kao command.cmd ili cmd.exe u 
zavisnosti od okru�enja, i Argument kao: 

/C copy c:\project\*.* F: 

Alternativno, ako koristimo promenljivu kao argument, radi omogu� avanja izmenjive putanje: 

/C copy $PROJ_DIR$\*.* F: 

 

 3.1.12. Source code control (upravljanje izvornim kôdom) 

 IAR Embedded Workbench mo�e da prepozna i pristupi bilo kom instaliranom source 
code control (SCC) sistemu uskla� enom sa SCC interfejsom koji je objavila Microsoft 
korporacija. Iz IDE-a mo�emo povezati IAR Embedded Workbench projekat sa eksternim SCC 
projektom, i izvršavati neke od naj� eš� e koriš� enih operacija. 

  3.1.12.1. Interakcija sa Source code control sistemima 

 U bilo kom SCC sistemu, koristimo aplikaciju tipa klijent za odr�avanje centralne arhive.  
U ovoj arhivi se � uvaju radne kopije fajlova projekta. Integracija SCC-a u IAR Embedded 
Workbench nam omogu� ava da lako izvršavamo nekoliko naj� eš� e koriš� enih SCC operacija 
direktno iz IDE-a. Ipak, nekoliko zadataka mora da bude obavljeno u aplikaciji tipa klijent. 

 Da bismo povezali IAR Embedded Workbench projekat sa source code control sistemom, 
trebalo bi da: 

�  U SCC aplikaciji tipa klijent, podesimo SCC projekat 
�  U IAR Embedded Workbench-u, pove�emo projekat sa SCC projektom. 

  3.1.12.2. Podešavanje SCC projekta u SCC  aplikaciji tipa klijent 

 Koristimo SCC klijentske alate za podešavanje radnog direktorijuma za fajlove u IAR 
Embedded Workbench projektu, koje �elimo da kontrolišemo koriš� enjem SCC sistema. Fajlovi 
mogu biti smešteni u jednom ili više poddirektorijuma osnovnog direktorijuma. Svi izvorni 
fajlovi moraju da se nalaze u istom direktorijumu kao ewp projektni fajl, ili da budu ugnje�deni 
u poddirektorijumima ovog direktorijuma. 
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  3.1.12.3. Povezivanje projekata u IAR Embedded Workbench-u 

 U IAR Embedded Workbench-u, pove�imo aplikaciju sa SCC projektom koriš� enjem 
slede� ih koraka:  

1. U radnom prozoru, izaberimo projekat za koji smo kreirali SCC projekat. Iz Project menija, 
izaberimo Source Code Control > Add Project To Source Control. Ova komanda je dostupna i iz 
kontekst menija koji se pojavljuje kad kliknemo desnim klikom bilo gde u radnom prozoru. 

Napomena: Komande u Source Code Control podmeniju su dostupne kada je dostupna makar 
jedna SCC klijentska aplikacija. 

2. Ako smo instalirali više verzija source code control sistema, pojavi� e se dijalog prozor u 
kome � emo izabrati sistem sa kojim �elimo da se pove�emo. 

3. Pojavljuje se SCC dijalog prozor gde se nalazi SCC projekat koji smo podesili. 

 
  3.1.12.4. Konfigurisanje source code control sistema 
 
 Da bismo source code control sistem prilagodili našim potrebama, izaberimo Tools > 
Options i kliknimo Source Code Control tab polje.  
 

 3.1.13. Kreiranje aplikacije  

  3.1.13.1. Podešavanje novog projekta 

 Pomo� u IAR Embedded Workbench IDE integrisanog razvojnog okru�enja, mo�emo 
kreirati napredne projektne modele. Kreiramo radni prostor kome dodajemo jedan ili više 
projekata. Postoje ve�  izra� eni projektni šabloni i za aplikacije i za biblioteke. Za svaki projekat 
mo�emo definisati  jednu ili nekoliko konfiguracija gra� enja. 

 Preporu� uje se kreiranje posebanog direktorijuma gde smeštamo sve projektne fajlove. 
Pre kreiranja novog projekta moramo kreirati radni prostor. 

   3.1.13.1.1. Kreiranje radnog prozora 

 Prvi korak je kreiranje novog radnog prostora za aplikaciju. Kada prvi put startujemo IAR 
Embedded Workbench IDE, tu se nalazi ve�  izra� eni radni prostor, koji mo�emo koristiti za 
tutorijal projekat. Ako koristimo taj radni prostor, mo�emo zanemariti prvi korak. 

 Izaberimo File > New > Workspace. Sada mo�emo kreirati projekat i dodati ga u radni 
prostor. 
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   3.1.13.1.2. Kreiranje novog projekta 

1. Da bismo kreirali novi projekat potrebno je izabrati Project > Create New Project. Pojavi� e se 
Create New Project dijalog prozor, koji nam oogu� ava da svoj novi projekat izgradimo na 
postoje� em projektnom šablonu.  

 

Slika 3.19: Create New Project dijalog prozor  

2. Proverimo da li je Tool chain postavljen na MSP430, i kliknimo OK. 

3. Za projekat iz ovog tutorijala izaberimo projektni obrazac Empty project, kojim kreiramo 
prazan  projekat koji koristi polazna projektna podešavanja. 

4. U standardnom Save As dijalog prozoru, nazna� imo direktorijum gde �elimo da smestimo 
projektni fajl, ili kreirajmo novi projektni direktorijum. Ukucajmo project1 u polje za upis imena 
fajla i kliknimo Save da bismo kreirali novi projekat. 

Projekat � e se pojaviti u radnom prozoru. 

 

Slika 3.20: Radni prozor 



�

���
�

 Kreiraju se dve konfiguracije gra� enja: Debug i Release. U ovom tutorijalu bi� e 
koriš� ena samo Debug konfiguracija. Konfiguraciju gra� enja biramo iz padaju� eg menija koji se 
nalazi na vrhu prozora. Zvezdica pored naziva projekta ozna� ava da postoje promene koje nisu 
sa� uvane. 

 Projektni fajl, sa ekstenzijom ewp, � e biti kreiran u projektnom direktorijumu, ne odmah, 
ve�  kasnije kada sa� uvamo radni prostor. Ovaj fajl sadr�i informacije o specifi� nim projektnim 
podešavanjima kao što su opcije gra� enja. 

5. Pre nego što projektu dodamo bilo koji fajl, potrebno je sa� uvati radni prostor. Izaberimo File 
> Save Workspace i nazna� imo direktorijum u koji �elimo da smestimo fajl radnog prostora. Za 
projekat iz ovog tutorijala, trebalo bi da ga smestimo novo-kreirani projektni direktorijum. 
Ukucajmo tutorials  u polje za upis imena fajla i kliknimo Save da bismo kreirali novi radni 
prostor. 

 

Slika 3.21: Dijalog prozor novog radnog prostora 

Ovim je, u projektnom direktorijumu, kreiran fajl radnog prostora, sa ekstenzijom eww.  
 
  3.1.13.1.3. Dodavanje fajlova projektu 
 
 Projekat iz ovog tutorijala koristi izvorne fajlove Tutor.c  i Utilities.c . 
�  Tutor.c  aplikacija je jednostavan program koji koristi samo standardne karakteristike C 
jezika. Zapo� inje niz sa prvih deset Fibonacci-jevih brojeva i ispisuje ih u konzoli pomo� u 

biblioteke �V�W�G�R�X�W. 

�  Utilities.c  aplikacija sadr�i rutine za Fibonacci kalkulacije.  
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1. U radnom prozoru, izaberimo mesto gde �elimo da dodamo izvorni fajl ili grupu.  
2. Izaberimo Project > Add Files da bismo otvorili standardni browse dijalog prozor. Na� imo 
fajlove Tutor.c  i Utilities.c , selektujmo ih na listi, i kliknimo Open da bismo ih dodali 
project1 projektu. 
 

 

Slika 3.22: Dodavanje fajlova projektu project1  

 

  3.1.13.1.4. Podešavanje opcija projekta 

 Za aplikacije, opcije mogu biti podešene na svim nivoima � vorova. Prvo � emo podesiti 
osnovne opcije tako da odgovaraju konfiguraciji procesora u ovom tutorijalu. Ove opcije moraju 
biti iste za celu konfiguraciju bildovanja i zato moraju biti podešene na projektnom � voru. 
 
1. Izaberimo ikonicu projektnog foldera project1 - Debug u radnom prozoru i Project > Options.  
Otvori� e se stranica Target iz General Options kategorije. 
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Slika 3.23: Podešavanje osnovnih opcija 

Proverimo da li su parametri podešeni kao što je dato u tabeli: 
 

Tabela 3.13: Osnovna podešavanja za project1 
 

Strana Parametri 

Target Device: msp430F149 

Output Output file: Executable 

Library Configuration Library: CLIB 

�

 
Zatim podesimo opcije kompajlera. 

 
2. Izaberimo C/C++ Compiler u Category listi da bi se prikazale strane sa opcijama kompajlera. 
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Slika 3.24: Podešavanje opcija kompajlera 

 
3. Proverimo da li su parametri podešeni kao što je dato u tabeli:  

 
Tabela 3.14: Opcije kompajlera za project1 
 

Strana Parametri 

Optimizations Optimizations, Size: None (Best debug support) 

Output Generate debug information 

List Output list file 
        Assembler mnemonics 

�

4. Kliknimo OK da bismo postavili opcije koje smo nazna� ili. 

Projekat je sada spreman za bildovanje. 

 3.1.13.2. Kompajliranje i linkovanje aplikacije  
 
 Sada mo�emo da kompajliramo i linkujemo aplikaciju. Potrebno je da kreiramo list  
fajl kompajlera i map fajl linkera. 
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  3.1.13.2.1. Kompajliranje izvornih fajlova 
 
1. Da bismo kompajlirali fajl Utilities.c , selektujmo ga u radnom prozoru. 
2. Izaberimo Project > Compile. 
 Alternativno, kliknimo Compile dugme u toolbar-u ili izaberimo komandu Compile iz 
kontekst menija koji se pojavljuje kada kliknemo desnim klikom na izabrani fajl u radnom 
prozoru.  
 Poruka o kompajliranju � e biti prikazana u Build messages prozoru. 
 

 
Slika 3.25: Poruka o kompajliranju 

 
3. Kompajlirajmo fajl Tutor.c  na isti na� in. 
 
 IAR Embedded Workbench IDE je kreirao nove direktorijume u projektnom 
direktorijumu. Pošto koristimo Debug konfiguraciju bildovanja, kreiran je Debug direktorijum 
koji sadr�i direktorijume List , Obj  i Exe: 
�  List  direktorijum je odredišni direktorijum za list  fajlove. List  fajlovi imaju ekstenziju 
lst . 
�  Obj  direktorijum je odredišni direktorijum za objektne (object) fajlove iz kompajlera i 
asemblera. Ovi fajlovi imaju ekstenziju r43  i koristimo ih kao ulaz IAR XLINK Linker-a. 
�  Exe direktorijum je odredišni direktorijum za izvršni fajl. Fajl ima ekstenziju d43  i koristimo 
ga kao ulaz IAR C-SPY® Debugger-a. Ovaj direktorijum je prazan sve dok ne linkujemo 
objektne fajlove. 
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Slika 3.26: Radni prozor nakon kompajliranja 

 
  3.1.13.2.2. Pregled List  fajla 
 
 Pri pregledu list  fajl kompajlera primeti� emo da se automatski a�urira. Vide� emo kako 
razli� iti nivoi optimizacije uti� u na veli� inu generisanog kôda. 
 
1. Otvorimo list  fajl Utilities.lst  tako što � emo kliknuti na njega duplim klikom u 
radnom prozoru. Pregledajmo list  fajl, koji sadr�i slede� e informacije: 
�  Zaglavlje prikazuje verziju proizvoda, informacije o tome kada je fajl kreiran, verziju opcija 
komandne linije kompajlera koje su koriš� ene. 
�  Telo list  fajla prikazuje asemblerski kôd i binarni kôd generisan za svaku naredbu. Tako� e 
prikazuje kako su promenljive dodeljene razli� itim segmentima. 
�  Kraj list  fajla prikazuje zahtevanu veli� inu magacina (steka), kôda i memorije i sadr�i 
informacije o greškama i porukama upozorenja koje su mo�da nastale. 
 
Obratimo pa�nju na veli� inu generisanog kôda na kraju fajla i ostavimo otvoren fajl. 
 
2. Izaberimo Tools > Options da otvorimo IDE Options diajlog prozor i kliknimo na Editor polje. 
Izaberimo opciju Scan for Changed Files. Ovom opcijom uklju� ujemo automatsko a�uriranje 
bilo kog fajla, npr. list  fajl, koji se otvori u editor prozoru. Kliknimo OK. 
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Slika 3.27: Postavljanje opcije Scan for Changed Files 

 
3. U radnom prozoru selektujmo fajl Utilities.c . Desnim klikom na selektovani fajl u 
radnom prozoru otvaramo C/C++ Compiler options dijalog prozor. Kliknimo na polje 
Optimizations i izaberimo opciju Override inherited settings. Iz Optimizations padaju� e liste 
izaberimo High. Kliknimo OK. 
 
4. Kompajlirajmo fajl Utilities.c . Primeti� emo dve stvari. Prvo, uo� imo automatsko 
a�uriranje otvorenog list  fajla zbog izabrane opcije Scan for Changed Files. Drugo, 
pogledajmo na kraj list  fajla i uo� imo promenu u veli� ini kôda zbog pove� ane optimizacije. 
 
5. Za ovaj tutorijal, trebalo bi koristiti nivo optimizacije None, pa pre nego što linkujemo 
aplikaciju, vratimo nivo optimizacije na polaznu vrednost. Otvorimo C/C++ Compiler options 
dijalog prozor desnim klikom na selektovani fajl u radnom prozoru. Deselektujmo Override 
inherited settings opciju i kliknimo OK. Ponovo kompajlirajmo fajl Utilities.c . 
 
   
 
  3.1.13.2.3. Linkovanje aplikacije 
 
 Sada treba da podesimo opcije za IAR XLINK Linker. 
 
1. Izaberimo ikonicu projektnog foldera project1 - Debug u radnom prozoru i Project > Options. 
Zatim izaberimo Linker u Category listi da bi se prikazale stranice za XLINK opcije. 
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Slika 3.28: Dijalog prozor XLINK opcija za project1 

 
Za ovaj tutorijal koriste se polazna fabri� ka podešavanja.  
 
  3.1.13.2.3.1. Izlazni format 
 
 Va�no je da izaberemo izlazni format koji odgovara našim potrebama. Ako �elimo da ga 
u� itamo u debugger treba� e nam izlaz sa informacijama za debagiranje. U ovom tutorijalu 
koristimo polazne opcije za izlaz, odgovaraju� e za C-SPY debugger. 
 Alternativno, u stvarnoj aplikaciji, ako �elimo da ga u� itamo u PROM programator, 
treba� e nam izlaz bez informacija za debagiranje, kao što je Intel-hex ili Motorola S-records.  
 
   
  3.1.13.2.3.2. Command fajl linkera 
 
 U command fajlu linkera, opcija XLINK komandne linije za kontrolu segmenata se 
koristi za postavljanje segmenata. Va�no je biti upoznat sa command fajlom linkera i 
postavljanjem segmenata. 
U ovom tutorijalu koristimo polazni command fajl linkera. 
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  3.1.13.2.3.3. Map fajl linkera 
 
 Po definiciji map fajl linkera nije generisan. Da bismo ga generisali, kliknimo na List tab 
polje i izaberimo opcije Generate linker listing, Segment map, i Module map. 
2. Kliknimo OK da sa� uvamo XLINK opcije. 
 Sada treba da linkujemo objektni fajl, da bismo generisali kôd koji mo�e biti debagiran.  
3. Izaberimo Project > Make. Informacije o procesu � e biti prikazane u Build messages prozoru. 
Rezultat linkovanja je kôdni fajl project1.d43  sa informacijama za debagiranje i map fajl 
project1.map . 
 
 3.1.13.2.4. Pregled map fajla  
 
 Pregledajmo fajl project1.map  da bismo videli kako su definicije segmenata i kôd 
smešteni u memoriji. Ovo su najzna� ajniji delovi map fajla: 
�  Zaglavlje  sadr�i opcije koriš� ene za linkovanje. 
�  CROSS REFERENCE deo prikazuje adresu ulaza programa. 
�  RUNTIME MODEL deo prikazuje runtime model atribute koji su koriš� eni. 
�  MODULE MAP prikazuje fajlove koji su linkovani. Za svaki fajl, prikazana je informacija o 
modulima koji su loadovani kao deo aplikacije, uklju� uju� i segmente i opšte simbole koji su 
deklarisani u svakom segmentu. 
�  SEGMENTS IN ADDRESS ORDER deo pikazuje sve segmente koji � ine aplikaciju. 
Aplikacija project1.d43  je sada spremna za pokretanje u IAR C-SPY Debugger-u. 
 

 
 
3.1.14. Debagiranje pomo� u IAR C-SPY® Debugger-a  
 
 U zavisnosti od toga koji paket IAR proizvoda smo instalirali, IAR C-SPY Debugger je 
mo�da uklju� en. Ovde se podrazumeva da koristimo C-SPY Simulator. 
 
 3.1.14.1. Debagiranje aplikacije 
 
 Kreirana project1.d43  aplikacija je sada spremna za startovanje u IAR C-SPY 
Debugger-u gde mo�emo da posmatramo promenljive, postavimo ta� ke prekida, posmatramo 
kôd u disasemblerskom modu, nadgledamo registre i memoriju, prika�emo izlaz programa u 
Terminal I/O prozoru. 
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  3.1.14.1.1. Startovanje debugger-a 
 
 Pre nego što startujemo IAR C-SPY Debugger moramo postaviti nekoliko C-SPY opcija. 
 
1. Izaberimo Project > Options, a zatim Debugger kategoriju. Na Setup stranici, izaberimo 
Simulator iz Driver padaju� e liste i selektujmo Run to main. Kliknimo OK. 
2. Izaberimo Project > Debug. Alternativno, kliknimo na Debugger dugme u toolbar-u. IAR C-
SPY Debugger startuje sa loadovanom project1.d43  aplikacijom.  
 
 Neka slede� i prozori i njihovi sadr�aji budu otvoreni i vidljivi na ekranu: radni prozor sa 
aktivnom konfiguracijom bildovanja tutorijali – project1, editor prozor sa izvornim fajlovima 
Tutor.c  i Utilities.c , i Debug Log prozor. 
 

 
 

Slika 3.29: Osnovni prozor C-SPY Debugger-a 
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  3.1.14.1.2. Nadgledanje izvornih naredbi 
 
1. Da bismo nadgledali izvorne naredbe, duplim klikom kliknimo na fajl Tutor.c  u radnom 
prozoru. 
2. Sa fajlom Tutor.c ��otvorenom u editor prozoru prelazimo na prvi korak sa Debug > Step 
Over komandom. 
Alternativno, kliknimo na Step Over dugme u toolbar-u. 
 
Trenutna pozicija bi trebalo da bude poziv init_fib  funkcije. 

 
 

Slika 3.30: Korak po korak u C-SPY-u 
 

3. Izaberimo Debug > Step Into da bismo prešli na izvršavanje naredbi iz tela  init_fib  
funkcije.  
Alternativno, kliknimo na Step Into dugme u toolbar-u. 
 Na nivou izvornog kôda, Step Over  i Step Into  komande nam omogu� avaju da 
izvršavamo aplikaciju naredbu po naredbu ili instrukciju po instrukciju. Step Into  nastavlja 
izvršavanje programa kroz telo funkcije ili naredbe potprograma, dok Step Over  izvršava 
svaki poziv funkcije u jednom koraku.  
 
4. Koristimo Step Into  komandu dok ne stignemo do for  petlje. 
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Slika 3.31: Koriš� enje Step Into  komande u C-SPY-u 

 
5. Koristimo Step Over  dok se ne vratimo na zaglavlje for  petlje. Primeti� ujemo da su 
jedini� ni koraci na nivou funkcije, ne na nivou naredbe. 
 Mogu� e je koristiti re�im korak po korak na nivou naredbe. Izaberimo Debug > Next 
statement da bismo izvršavali jednu po jednu naredbu. Alternativno, kliknimo na Next statement 
dugme u toolbar-u.  
 
  3.1.14.1.3. Nadgledanje promenljivih  
 
 C-SPY nam omogu� ava da posmatramo promenljive ili izraze u izvornom kôdu, tako da 
mo�emo da pratimo njihove vrednosti dok izvršavamo aplikaciju. Promenljivu mo�emo 
posmatrati na mnogo na� ina, na primer, pokazuju� i na nju strelicom miša u prozoru izvornog 
kôda, ili otvaranjem nekog od prozora Locals, Watch, Live Watch, ili Auto.  
 
   3.1.14.1.3.1. Koriš� enje Auto prozora 
 
1. Izaberimo View > Auto da otvorimo Auto prozor. 
U Auto prozoru � e biti prikazana trenutna vrednost nedavno modifikovanih izraza. 
 

 
 

Slika 3.32: Nadgledanje promenljivih u Auto prozoru 
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2. Nastavimo korak po korak da vidimo kako se vrednost menja. 
 
   3.1.14.1.3.2. Postavljanje  watchpoint-a 
 
 Koristi� emo Watch prozor za nadgledanje promenljivih. 
 
3. Izaberimo View > Watch da otvorimo Watch prozor. Primetimo da je spojen sa trenutno 
otvorenim Auto prozorom; prozori su smešteni kao grupa u tab polju. 
4. Postavimo watchpoint na promenljivu i  prate� i slede� u proceduru: Kliknimo na isprekidani 
pravougaonik u Watch prozoru. U polju za unos koje se pojavi, ukucajmo i  i pritisnimo Enter. 
Tako� e mo�emo da prevu� emo promenljivu iz editor prozora u Watch prozor.  
5. Selektujmo root  niz u init_fib  funkciji i prevucimo ga u Watch prozor. U Watch prozoru 
� e biti prikazana trenutna vrednost i  i root . Mo�emo da proširimo root  polje za detaljniji 
pregled. 

 
 

Slika 3.33: Posmatranje promenljivih u Watch prozoru 
 
6. Izvršimo još nekoliko koraka da vidimo kako se menjaju vrednosti promenljivih i  i root .  
7. Da uklonimo promenljivu iz Watch prozora, selektujmo je i pritisnimo Delete. 
 
 3.1.14.1.4. Postavljanje i nadgledanje ta� aka prekida 
 
 IAR C-SPY Debugger sadr�i dobar sistem za ta� ke prekida. 
Najlakši na� in je da se ta� ke prekida postave jednostavnim pozicioniranjem ta� ke umetanja u ili 
blizu naredbe i biranjem Toggle Breakpoint komande. 
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1. Postavimo ta� ku prekida na naredbu get_fib(i)  prate� i slede� u proceduru: Prvo, kliknimo 
na Utilities.c  polje u editor prozoru i kliknimo na naredbu da bismo postavili ta� ku 
umetanja. Zatim izaberimo Edit > Toggle Breakpoint.  
Alternativno, kliknimo na Toggle Breakpoint dugme u toolbar-u. 
Ta� ka prekida � e biti postavljena na ovu naredbu. Naredba � e biti markirana i na margini � e biti 

�  da poka�e da se tu nalazi ta� ka prekida. 

 

 
 

Slika 3.34: Postavljanje ta� aka prekida 
 
 Da bismo videli definisane ta� ke prekida, izaberimo View > Breakpoints da bi otvorili 
Breakpoints prozor. Informacije o izvršenju do ta� ke prekida mo�emo na� i u Debug Log 
prozoru. 
 
  3.1.14.1.4.1. Izvršavanje do ta� ke prekida 
 
2. Da bi se aplikacija izvršavala dok ne stigne do ta� ke prekida, izaberimo Debug > Go.  
Alternativno, kliknimo na Go dugme u toolbar-u. 
 
 Aplikacija � e se izvršavati do ta� ke prekida koju smo postavili. U Watch prozoru � e biti 
prikazana vrednost root  izraza, a u Debug Log prozoru � e biti informacije o ta� ki prekida. 
3. Da bismo uklonili ta� ku prekida, selektujmo je i izaberimo Edit > Toggle Breakpoint. 
 
 3.1.14.1.5. Debagiranje u disasemblerskom modu  
 
 Debagiranje sa C-SPY-jem je obi� no br�e i jednostavnije u C/C++ re�imu rada. Ipak, ako 
�elimo da imamo potpunu kontrolu nad rutinama niskog nivoa, mo�emo debagirati u 
disasemblerskom re�imu rada gde svaki korak odgovara jednoj asemblerskoj instrukciji. C-SPY 
dozvoljava da slobodno prelazimo iz jednog re�ima rada u drugi. 
1. Prvo resetujmo aplikaciju klikom na Reset dugme u toolbar-u. 
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2. Ako Disassembly prozor nije otvoren, izaberimo View > Disassembly da bismo ga otvorili. 
Vide� emo asemblerski kôd koji odgovara trenutnoj C naredbi. 
 

 
Slika 3.35: Debagiranje u disasemblerskom re�imu rada 

 
 
 
 
 3.1.14.1.6. Nadgledanje registara 
 
 Register prozor nam omogu� ava da nadgledamo i menjamo sadr�aj registara procesora. 
1. Izaberimo View > Register da otvorimo Register prozor. 
 

 
Slika 3.36: Register prozor 

 
2. Uradimo Step Over  da izvršimo slede� u instrukciju i posmatrajmo kako se vrednosti 
menjaju u Register prozoru. 
3. Zatvorimo Register prozor. 
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 3.1.14.1.7. Nadgledanje memorije 
 
 Memory prozor nam omogu� ava da nadgledamo selektovane delove memorije. U 
slede� em primeru, posmatramo deo memorije koji odgovara promenljivoj root . 
1. Izaberimo View > Memory da otvorimo Memory prozor. 
2. Pokrenimo Utilities.c  prozor, selektujmo root  i prevucimo ga iz prozora C izvornog 
kôda u Memory prozor. 
 
U Memory prozoru � e biti selektovan sadr�aj memorije koji odgovara promenljivoj root . 
 

 
Slika 3.37: Nadgledanje memorije 

 
3. Da bismo sadr�aj memorije prikazali kao 16-o bitne jedinice podataka, izaberimo x2 Units 
komandu iz padaju� eg menija u toolbar-u Memory prozora.  
 

 
Slika 3.38: Prikaz sadr�aja memorije kao 16-o bitne jedinice podataka 

 
 Ukoliko do sada nismo sve memorijske jedinice inicijalizovali init_fib  funkcijom C 
aplikacije, nastavimo step over ; primeti� emo kako � e sadr�aj memorije biti a�uriran. 
Mo�emo promeniti sadr�aj memorije korekcijom vrednosti u Memory prozoru. Stavimo ta� ku 
umetanja na sadr�aj memorije koji �elimo da korigujemo i ukucajmo �eljenu vrednost. 
Zatvorimo Memory prozor. 
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 3.1.14.1.8. Pregled Terminal I/O-a 
 
 Ponekad � e biti potrebno da debagiramo konstrukcije u aplikaciji koje koriste stdin  i 
stdout  bez hardverske podrške. C-SPY nam omogu� ava da simuliramo stdin  i stdout  
koriš� enjem Terminal I/O prozora.  
Napomena: Terminal I/O prozor je dostupan u C-SPY-u jedino ako smo linkovali projekat 
koriš� enjem opcije izlaza With I/O emulation modules.  
 
1. Izaberimo View > Terminal I/O da prika�emo izlaz iz U/I operacija. 
 

 
Slika 3.39: Izlaz iz U/I operacija 

 
Sadr�aj prozora zavisi od toga dokle smo stigli sa izvršavanjem aplikacije. 
 
 3.1.14.1.9. Kraj programa 
 
1. Da bismo završili izvršenje aplikacije, izaberimo Debug > Go. 
Alternativno, kliknimo na Go button u toolbar-u. 
 
Kako ne nailazi na ta� ke prekida, C-SPY sti�e do kraja aplikacije i poruka program exit reached 
se pojavljuje u Debug Log prozoru. 
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Slika 3.40: Kraj programa u C-SPY-u 

 
Svi izlazi iz aplikacije su sada prikazani u Terminal I/O prozoru. 
 Ako ponovo �elimo da startujemo postoje� u aplikaciju, izaberimo Debug > Reset, ili 
kliknimo na Reset dugme u toolbar-u. 
 
2. Da bismo izašli iz C-SPY-a, izaberimo Debug > Stop Debugging. Alternativno, kliknimo na 
Stop Debugging dugme u toolbar-u. Prikaza� e se Embedded Workbench radni prostor. 
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3.2. Code Composer Essentials (CCE) 

 Code Composer Essentials (CCEssentials) je potpuno integrisano i lako za koriš� enje, 
razvojno okru�enje koje se koristi za programiranje i debagiranje MSP430 mikrokontrolera sa 
mikro potrošnjom. 

CCEssentials je baziran na Eclipse open source platformi. 

Podr�ava razvoj softvera u C-u i u asemblerskom jeziku. 

 Code Composer Essential's potpuno integrisan Host Tools sadr�i: 

·  MSP430 C kompajler, asembler i linker 
·  Source Code debugger 
·  Integrisani Visual Project Manager 
·  Virtualne i hardverske ta� ke prekida 
·  Integrisani editor  

  
 3.2.1. Kreiranje projekta 

 Kreiranje projekta � ine slede� i koraci: 

1. Pokrenimo CCE (Start > All Programs > Texas Instruments > Code Composer Essentials 2.0 
> Code Composer Essentials 2.0). 

2. Kreirajmo novi projekat klikom na File > New > Project > C > Managed Make C/ASM 
Project (preporu� eno). Kliknimo Next i unesimo ime za projekat. Klik� imo Next dok ne 
stignemo do Device Selection stranice. Odaberimo odgovaraju� i ure� aj i kliknimo Finish. 

3. Kreirajmo novi tekstualni fajl klikom na File > New > Source File. Obavezno stavljamo sufiks 
.c ��ili .asm . 

4. Unesimo tekst programa u fajl. 

Napomena: Koristimo fajlove sa ekstenzijom h da pojednostavimo razvoj kôda. 

 CCE sadr�i fajlove koji definišu registre i imena bitova, za svaki ure� aj i oni mogu 
mnogo da pojednostave razvoj programa. Ovi fajlovi se nalaze u <Installation 
Root>\tools\compiler\msp430\include\ . Uklju� imo odgovaraju� i .h  fajl, za ciljni 
ure� aj, u tekst fajl (#include "msp430xyyy.h" ). 

5. Podesimo opcije projekta (Project > Properties), ili prihvatimo polazna fabri� ka podešavanja. 

6. Bildujmo projekat (Project > Build Active Project). 
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7. Debagirajmo aplikaciju (Run > Debug Active Project). Ovim startujemo debugger GDB430 i 
sada on preuzima kontrolu nad ure� ajem, briše memoriju ure� aja, programira je aplikacijom i 
resetuje ure� aj. 

8. Kliknimo Run > Run da bismo startovali aplikaciju. 

9. Kliknimo Run > Terminate da bismo stopirali aplikaciju, i izašli iz debugger-a GDB430-a. Za 
povratak u editor kôda idemo na Window > Open Perspective > C/C++. 

10. Kliknimo File > Exit da bismo izašli iz programa CCE. 

 

 3.2.2. Projektna podešavanja 

 Podešavanja kojima konfigurišemo CCE su brojna i detaljna. Ve� inu projekata mo�emo 
kompajlirati i debagirati koriš� enjem polaznih fabri� kih podešavanja. Da bismo podesili aktivni 
projekat izaberimo Project > Properties.  

 Preporu� uju se slede� a podešavanja: 

• Nazna� imo ciljni ure� aj za fazu debagiranja (Project > Properties > Debug Properties > 
Device) 

• Da bismo najlakše debagirali C projekat, onemogu� imo optimizaciju (Project > Properties > 
C/C++ Build > MSP430 Compiler > Optimization). 

• Nazna� imo putanju pretrage za C preprocesor (Project > Properties > C/C++ Build > MSP430 
Compiler > General Options). 

• Nazna� imo putanju pretrage za sve koriš� ene biblioteke (Project > Properties > C/C++ Build 
> MSP430 Executable Linker). 

• Nazna� imo interfejs za debugger. Izaberimo Project > Properties > Debug Properties > 
Connection > LPTx za paralelni FET interfejs ili USB Emulator za USB interfejs. 

• Omogu� imo brisanje Main i Information memorija pre nego što se daunloaduje kôd (Project > 
Properties > Debug Properties > Erase Main and Information Memory) 

• Da poboljšamo performanse sistema tokom debagiranja, isklju� imo Virtual Breakpoints 
(Project > Properties > Debug Properties > Use Virtual Breakpoints) 
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 3.2.3. Koriš� enje postoje� eg CCE V1.x projekta 

 CCE 2.0 ne podr�ava u potpunosti prebacivanje radnih prostora i projekata, koji su 
kreirani u verziji 1.0, u verziju 2.0. Mo�emo da pregledamo fajlove koji se nalaze u projektu, ali 
problemi nastaju kada projekat treba da bildujemo ili debagiramo. 

 Da bismo projekat iz CCE 1.0 koristili u CCE 2.0, moramo ga konvertovati. Kreirajmo 
novi projekat i dodajmo originalne projektne fajlove novom projektu. Nakon što kreiramo 
projekat, opcije za kompajliranje, linkovanje i debagiranje moramo a�urirati tako da odgovaraju 
v1.0 opcijama. 

 

 3.2.4. Upravljanje magacinom 

 Rezervisanu veli� inu magacina mo�emo konfigurisati u opcijama projekta (Project > 
Properties > C/C++ Build > MSP430 Executable Linker > General Options > Set C System 
Stack Size). Veli� ina magacina zauzima 50 do 80 bajtova po� ev od poslednje lokacije RAM-a 
(npr., magacin se prostire kroz RAM nani�e za 50 do 80 bajtova, u zavisnosti od veli� ine RAM-a 
izabranog ure� aja). 

 Do prekora� enja magacina mo�e do� i zbog male veli� ine ili grešaka u aplikaciji. 

 

 3.2.5. Generisanje fajlova Texas Instruments .TXT (i drugih binarnih formata)  

 CCE instalacija sadr�i alat za konverziju hex430.exe. Ovaj alat mo�emo konfigurisati 
tako da generiše izlazne objekte u TI-TXT formatu za koriš� enje u GANG430 i PRGS430 
programatorima.  
 Alat se nalazi u <Installation Root>\tools\compiler\msp430\bin . 
 Post-build step mo�emo konfigurisati da generiše TXT fajl automatski posle svakog 
bildovanja (Project > Properties > C/C++ Build/Build Steps/Post-Build Step). Mo�emo odabrati 
i Intel i Motorola heksadecimalni format. 
 
 3.2.6. Pregled primera programa 

 Primeri programa za MSP430 ure� aje nalaze se u <Installation 
Root>\examples .��

Da bismo koristili postoje� e primere, kreirajmo novi projekat i dodajmo mu izvorni (source) fajl 
iz primera. (Project > Add Files to Active Project). 
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 3.2.7. Koriš� enje integrisanog debugger-a GDB430  

  3.2.7.1. Tipovi ta� aka prekida 

 Mehanizam debugger-a za ta� ke prekida koristi ograni� ene resurse na � ipu. Kada 
postavimo n ili manje ta� aka prekida, aplikacija radi punom brzinom (ili "Realtime" (“u realnom 
vremenu”)). Kada postavimo više od n ta� aka prekida i uklju� imo Use Virtual Breakpoints 
(Project > Properties > Debug Properties > Use Virtual Breakpoints), aplikacija radi pod 
kontrolom ra� unara; sistem radi mnogo sporije, ali nudi neograni� eni broj softverskih ta� aka 
prekida (ili "Non-Realtime"). Tokom Non-Realtime re�ima rada, ra� unar izvršava instrukcije 
korak po korak i nakon svake ispituje da li je dostignuta ta� ka prekida. 

 Mo�emo koristiti code  (address) i data  (value) ta� ke prekida. �'�D�W�D ta� ke prekida i 

�U�D�Q�J�H ta� ke prekida zahtevaju dve MSP430 hardverske ta� ke prekida. 

 

  3.2.7.2. Koriš� enje ta� aka prekida 

 Ako GDB430 debugger startujemo sa više od n postavljenih ta� aka prekida i ako 
isklju� imo virtualne ta� ke prekida, dobijamo poruku da ne mogu sve ta� ke prekida da budu 
odobrene. CCE dozvoljava postavljanje bilo kog broja ta� aka prekida, bez obzira na Use Virtual 
Breakpoints konfiguraciju CCE-a. Ako isklju� imo virtualne ta� ke prekida, u debuggeru GDB430 
mo�emo postaviti maksimalno n ta� aka prekida. 

 Da bi resetovali program moramo postaviti ta� ku prekida na adresi definisanoj u Project 
> Properties > Debug Properties > Run To. 

 Run To Cursor operacija privremeno zahteva ta� ku prekida. 
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